can't publish services to ArcGIS Server

3556
9
01-27-2018 04:24 PM
SaraEL_MALKI
Occasional Contributor II

Hi guys,

I've already workd with ArcServer for years, and Now I've changed my laptop and needed to install the softwares all over again,

I'm using a geodatabase (PostgreSQL), and succeded to connect to it as an enterprise geodatabase,

successfully connected to ArcGIS Server and registred it my geodatabase.

(working with ArcGIS 10.2)

but once I wanted to publish a map service, an error is displayed,when trying to publish a service

I have tried to google the error but none of the tricks helped,

Error: Packaging succeeded, but publishing failed. ERROR: unable to connect to publishing tools serv...  because I've already gone through these stuffs, I don't remeber at all having to create roles in the server manager as that links suggest,

when I tried to give all the permissions to arcgisserver directory,

It displayed that error: (which is about that an error occured while applying the changes. access denied) when I clicked continue it gives the full control to the folder (data-store, directories-logs)

access denied

I tried to restart the publishing service but it failed showing that arror:

restarting Publishing service

and just then I discovered that all the system services of the server are empty of tools:

empty services

I am stuck right now, please if you pass by here tag someone who can help me in this, because the docs contains a lot of text meanwhile I need sceenshots to explain me the possible solutions.

(I am on local machine, so my server is localhost & I've configured the web adaptor with the server)

Derek Law‌ Rebecca Strauch, GISP Robert Scheitlin, GISP 

0 Kudos
9 Replies
DerekLaw
Esri Community Moderator

Hi Sara,

If you've tried the various troubleshooting suggestions in the Esri KB doc #000013246 (you referenced),

Error: Packaging succeeded, but publishing failed. ERROR: unable to connect to publishing tools serv... 

and were unable to address your problem, I doubt that anyone on the forums can help further.

When you attempted to restart your GP publishing service and got the ArcGIS Server error message, was there a log file in the location specified? c:\arcgisserver\logs\SIG-SARA\errorreports

I suggest you contact Esri Tech Support so they can help look into your issue further.

Hope this helps,

SaraEL_MALKI
Occasional Contributor II

Publishing service error

for the  exception information it says: "The thread tried to read from a virtual address or write to a virtual address for which it does not have appropriate access"

I'm working on localhost, in a windows admin account: 

 

I don't know which access I can give ? and how to do so ?

0 Kudos
shan_sarkar
Regular Contributor

Sara,

Did you try logging in the Admin REST page and then try to restart the Publishing GP service? Do you still receive the same error?

~S


~Shan
0 Kudos
RandallWilliams
Esri Regular Contributor

What OS are you working with? Is ArcGIS server installed on the same machine as ArcGIS Desktop?

SaraEL_MALKI
Occasional Contributor II

I am on windows 7 pro. 

Yes on the same machine. When I have installed ArcGIS server it created an other session and I made it an administrator

0 Kudos
RandallWilliams
Esri Regular Contributor

Upgrade to 10.2.2 and apply this patch:

https://support.esri.com/en/download/7576

I'm betting that your new machine has the Microsoft patch that breaks GP on Windows 7 and 2008. 

SaraEL_MALKI
Occasional Contributor II

Thank you mister Williams;

Will the problem be solved if I upgrade to windows 10 ?

0 Kudos
RandallWilliams
Esri Regular Contributor

Assuming that this is indeed the same issue, yes. However, I'd still update to 10.2.2 at a minimum, preferably a more recent version that's fully supported.

ThomasSteudel1
Occasional Contributor

Is this patch for ArcGIS Version 10.2.2 working?

Our Software-Provider told me last week, that we have to upgrade to 10.4 before i can use the patch. So now i am not able to publish anything.... Even publishing the .sd files via the ArcGIS Server Manager does not work. The "uploading" process takes ages - so i had to stop it after 10 minutes. 

 

Is there another way to publish my services? Thanks alot and thanks for the patch-solution!

0 Kudos