Filtered select_multiple choice list does not populate domain value in HFL

146
2
08-11-2021 05:45 AM
MeghJones
New Contributor II

Hello! 

I am experiencing an issue where I setup a filtered select_multiple choice list in my S123 Connect form and when published, those questions specifically do not populate a list of domain values. 

Is this a bug or is there a work around for this behavior? 

Thank you in advance! 

@JamesTedrick @ZacharySutherby @IsmaelChivite 

0 Kudos
2 Replies
DougBrowning
MVP Frequent Contributor

Domains are only set on the first publish, after that they do not update at all.  Long known issue.

But select multiple have no domains.  There are some posts on using jr choice you could look into.  Also a repeat may work better.  Storing comma lists are really hard to deal with in the data.

Please upvote here  - 

https://community.esri.com/t5/arcgis-survey123-ideas/have-an-option-where-survey123-dropdown-list-an...

and

https://community.esri.com/t5/arcgis-online-ideas/syncing-updated-domains-in-survey123-connect-and/i...

Some options manually

https://community.esri.com/t5/arcgis-survey123-questions/how-do-i-add-domains-choices-to-survey123-s...

hope that helps

0 Kudos
jcarlson
MVP Regular Contributor

A select_multiple field doesn't actually have a domain. Though you define your choices and labels in Survey123, what is stored in that field is a comma-delimited string: "choice1,choice5,choice2", etc. And if I recall correctly, the order in which those items appear is based on the order they are clicked in the survey.

A domain, on the other hand, is for associating unique values with labels. Given the way the field's contents are stored, you will end up with many more unique values than the number of choices.

What is it you wish to do with the values? You can use an Arcade expression to decode values and pull out matching strings.

- Josh Carlson
Kendall County GIS
0 Kudos