Exported map missing lines version (Pro V2.7)

7450
42
Jump to solution
12-20-2020 03:16 PM
Labels (1)
JessicaStrauss
New Contributor

Any ideas would be appreciated.

Since updating to Pro Version 2.7 last week all outputs (Jpeg, Png, PDF) are all missing graphic lines (feature ones are fine just those used for borders etc. I have searched but can't work it out.

Example 1: This is on the layout view - this is what we want as the output

JessicaStrauss_3-1608506000668.png

 

Example 2: This is the exported view

JessicaStrauss_2-1608505985836.png

 

1 Solution

Accepted Solutions
TomBole
Esri Regular Contributor

Hello Everyone, 

We have addressed this issue - BUG-000136364 - and the fix should be available with ArcGIS Pro 2.7.1. We're confident that the fix addresses the scenarios outlined in this thread and provided by those who contacted Support. But just incase, if you have installed this patch and are still seeing issues with graphics being dropped from the output please contact Support

Thanks to all who participated in this thread. It means a lot to hear from all of you - the good and the bad.

Tom

View solution in original post

42 Replies
TomBole
Esri Regular Contributor

Hi Jessica, 

I'm not aware of any outstanding issue regarding the dropping of graphic lines from an exported layout. At the moment I can't think of anything that might cause a problem like this. 

Can you contact Esri Support? They are better equipped to handle troubleshooting steps and gather bug data. They can be contacted at https://support.esri.com/en/contact-tech-support.

Thanks, 

Tom

MichaelStandart2
New Contributor

Our group ran into this today and as a work around we copy and pasted the Rectangle Elements, and deleted the original ones that were not exporting, and that worked.

ClintonMcComb1
New Contributor II

I too ran into this issue and your recommendation worked for me also. I didn't even have to delete the old ones, just pasted the copied elements on top. Thanks!

MichaelAugust
Occasional Contributor III

This is indeed happening to us as well, we have some boxes and lines that serve as a title block, on all of our previously created Pro figures now, these graphics are dropped/missing when we export to pdfs.  Also our legends don't function correctly either, we seem to lose the ability to drag/drop layers from existing Pro projects, we end up having to recreate all of our legends too.

Can someone look into this? Happened right after Pro upgrade to 2.7 with three of our analysts on 6 different machines.

0 Kudos
TomBole
Esri Regular Contributor

Hi Michael, 

Sorry you are running into problems. Before we can do anything about the problem we have to be able to reproduce this issue so a developer can then step through the code to see what exactly is causing the bug.

I mention 2 issues:

1. Some Graphics present in the layout are not displaying in the exported file

As stated earlier we are unaware of any issues with 2.7 and cannot reproduce the stated problem. With our test maps we see all expected graphics on the layout in the exported file.

2. You can no longer drag/drop layers into legends.

I'm not aware of any known issue concerning this functionality in 2.7. I'm able to drag/drop new layers into both the legend on the layout page and into the legend item in the Contents pane. 

I'm sure you and others are running into problems, but until we can reproduce (with clear steps & data) either issue there is only guesswork.  Can you contact Esri Support? They are better equipped to handle troubleshooting steps and gather bug data. They can be contacted at https://support.esri.com/en/contact-tech-support.

Thanks, 

Tom

0 Kudos
MichaelAugust
Occasional Contributor III

Yes - I'll contact support - my post was mostly to acknowledge that, like the original poster, we are seeing the exact same behavior - thanks!

0 Kudos
EricCreighton
New Contributor II

I am also having the same issue as stated above.  Interested to see what the resolution is.

by Anonymous User
Not applicable

I am also having this issue.

0 Kudos
TomBole
Esri Regular Contributor

All, 

Currently, we believe that the lines are getting dropped during the exporting process through the UI.  This is being investigated as we have found a single case where this is occurring.

We've also have discovered, with this specific case, that exporting the layout via python (ArcPy.mp) includes the expected lines as expected in the exported file. This may provide a workaround until we have identified the bug and engineered a solution.

You can open the Python window from the View tab on the ribbon.

Screenshot 2020-11-19 053457.png

The following code, when pasted into the Python window and run, will export every layout in the project to a PDF file in C:\temp. For map series in the project, only a single page will be exported.

##Export to PDF
aprx = arcpy.mp.ArcGISProject("CURRENT")
aprx.listLayouts()
for lyt in aprx.listLayouts():
#Parameters: output name, resolution, image quality, compress vector graphics, image compression, embed fonts, layer attributes, georeference, jpeg compression, clip to elements, output as image, embed color profile
#Image quality: "BEST", "BETTER", "NORMAL", "FASTER", "FASTEST"
#Image compression: "ADAPTIVE", "DEFLATE", "JPEG", "LZW", "NONE", "RLE"
#Layer attributes: "LAYERS_ONLY", "LAYERS_AND_ATTRIBUTES", "NONE"
lyt.exportToPDF(f"C:\Temp\{lyt.name}.pdf", 150, "BEST", True, "ADAPTIVE", True, "LAYERS_ONLY", True, 80, False, False, False)
print("Done")

 For more information on ArcPy please see - https://pro.arcgis.com/en/pro-app/latest/arcpy/mapping/tutorial-getting-started-with-arcpy-mp.htm

At the bottom of this topic is a section on exporting to PDF.

Sorry for the inconvenience and I hope this work around helps.

Tom