Select to view content in your preferred language

Backward compatibility issue for ArcGIS Pro style file (*.stylx)

813
5
06-07-2023 01:15 AM
Labels (2)
xingchenc
Occasional Contributor

Hi everyone,

        I have created a style file (*.stylx) in ArcGIS Pro 3.0 and would like to distribute it to users who are using lower version of ArcGIS Pro(like 2.8, 2.9). An error occured("The version of the selected style is not supported or is otherwise invalid. Please select a valid .stylx file.") when they trying to add the style file into their ArcGIS Pro project , was wondering if there is any solution that can share the stylx file from higher version of ArcGIS Pro to lower version of ArcGIS Pro?

xingchenc_0-1686126128967.png

 

        Thanks!

 

Updated info

Here is what I found so far:

This issue only exists for 3.x style file loaded into 2.x Pro.

Style file created in 2.x seems to be fine(i.e. style file created in ArcGIS Pro 2.8 will have no issue loading into ArcGIS Pro 2.5).

 

0 Kudos
5 Replies
BarryNorthey
Occasional Contributor III

From the Help:

Unsupported styles

If the status indicates that the style is not supported, it is because the style was created in or upgraded by a newer version of ArcGIS Pro, or the style is somehow corrupt. Check the path where the style is located; a copy of the style for the correct version may have been generated. Add that version instead.

0 Kudos
xingchenc
Occasional Contributor

Hi Barry,

Thanks for the help, I have checked the path,  but there isn't any other style file. 

0 Kudos
Robert_LeClair
Esri Notable Contributor

So ArcGIS Pro 3.x is a breaking release meaning that 3.x files cannot be opened in ArcGIS Pro 2.x.  You can read more about it here.  One workflow to attempt is to create a project package and open it using ArcGIS Pro 2.x.  Does the *.stylx open in ArcGIS Pro 2.x?

0 Kudos
xingchenc
Occasional Contributor

Hi Robert,

      @Robert_LeClair Thanks for the suggustion, unfortunately, I have already tried packing the whole project as a PPKX file and opened it in ArcGIS Pro 2.8. still no luck(same error message).

     While reading your reply on another post(link here: Re: Add Stylx error: The version of the selected s... - Esri Community), I found this trick actually works. The only drawback is you can only upload selected few style types like point/line/polygon/text style, other style type like Maplex placement style will not be uploaded to portal.

    Please let me know if there is any better solutions, thanks!

0 Kudos
Robert_LeClair
Esri Notable Contributor

Hi @xingchenc - I'll keep you posted on anything I learn!

0 Kudos