ArcGIS Power BI Issues from latest release

3476
7
09-02-2021 11:53 AM
NathanWatermeier
New Contributor

We noticed several issues occurring as a result of the latest release of Power BI desktop within the past few days. Not sure if these are related to the other posting "Maps got broken in the last update" so I am posting specific issues we discovered.

1) Users unable to login to Enterprise Portal - blank screen login or unable to login once 'Sign in' has been selected, no prompts or logins occur.

2) Losing settings in maps. When you click on other Power BI pages (worksheets - bottom tabs) the settings for the map layer that is created on map page view disappears. We found we have to select save first after edits before going to other pages. It should be autosaving.

3) When configuring counties and states in the map settings we keep getting the following alert. When we select the link in the alert we lose settings in the map. Will this error show up in the future once it is published to our server for others to view? We have tried uploading county and state names along with FIPS Codes to see if there would be any changes but still getting info box.

NathanWatermeier_1-1630607905835.jpeg

4) Constant spinning of map in top right of window.

NathanWatermeier_0-1630607741600.jpeg

We are running Power BI Desktop Version: 2.96.1061.0 64-bit (August 2021).

We installed Version: 2.95.983.0 64-bit (July 2021) - Previous monthly updates to Power BI Desktop and the Power BI service - Power BI | Microsoft Docs 

We were able to login much better, however lose some of the newer functionality in latest release.

7 Replies
AnthonyLatini
Esri Contributor

@NathanWatermeier -  Hello there! My name is Anthony and I am a product engineer on the ArcGIS for Power BI visual. I was looking over this issue and I would like to help out if I can! 🙂

Thank you for providing me with the versions of Power BI Desktop that you are running. In some cases, there could be caching issues with each version, so it would be good to rule that out. 

Below are my findings from your list. Let's see if we can resolve them! 

For items 1 and 2, I am unable to reproduce them on my machine and in a clean environment. For items 1 and 2, it might be good to clear the cache of Power BI Desktop and restart the application and your machine. There is a chance that something is left over from the previous version of ArcGIS for Power BI that is causing some issues. 

 

 

There are two areas where the cache can be cleared in Power BI Desktop. 

  1. Within Power BI Desktop, navigate to File > Options and settings > OptionsAnthonyLatini_0-1630940594284.png
  2. Under Data load, click the Clear cache button under the three sections highlighted in the screenshot below.
    AnthonyLatini_2-1630940745361.png
  3. Close out of Power BI Desktop
  4. On your local system, browse to the following folder location: %LocalAppData%\Microsoft\Power BI Desktop.

    For example, <user>\AppData\Local\Microsoft\Power BI Desktop

  5. Delete the folder named CEF.
  6. Reboot your machine

 

For items 3 and 4, I was able to reproduce these items on my machine and have logged an issue to resolve this in an upcoming patch. I have made some notes in that issue that references this case so that I can test it once the fix has been applied. As a note, the message at the bottom of the screen should not appear for viewers of the report. If it is appearing, please let me know so that I can add it to our issue! 

If possible, would you be able to share the dataset you are using so that I can use your data to make sure the issue has been resolved? 

Looking forward to working with you on this! 😀

AJW
by
New Contributor II

Hi - In case it helps I can also confirm that we are seeing the message at the bottom of the screen as part of the issue logged in relation to inability to map data to UK census (LSOA) areas or run existing reports with including that since the latest release.  

AJW_0-1630998746806.jpeg

 

0 Kudos
AnthonyLatini
Esri Contributor

@AJW - This helps me out greatly! I will add this to an existing issue we have in our project that is addressing these items. 

0 Kudos
eugenecotan
New Contributor

Hi @AnthonyLatini, I came across this article while looking for a solution to my problem.  I don't know how to contact any of ESRI's or ArcGIS' tech support.  My name is Eugene Tan and I'm currently running the Power BI Desktop version 2.99.621.0 64-bit (November 2021).  I downloaded this app from the Microsoft Store.  Prior to installing the app, I was running the exe version one, also on the November 2021 build.  I noticed that Nathan mentioned in his comment, particular on the first item, that a blank screen appeared after clicking on the "sign in" button.  I have an organizational account with ArcGIS, and I am also encountering the same problem.  All I get is a blank page; I'm not getting any prompt on my account details so I cannot proceed with logging in into my account.  I'm currently using Windows 11 Insider edition.  I don't know if that is a factor but I also have a laptop running the regular Windows 11, also using the Power BI Desktop November build downloaded from the Microsoft Store.  I do not experience the same issue with that machine.  I do hope you can give me some tips on how to resolve the issue.  Thank you very much.

0 Kudos
eugenecotan
New Contributor

I was able to log in again to my ArcGIS account once I uninstalled the November build.  I am now using the October version and I can confirm that ArcGIS visual is working again.  Thank you

 

0 Kudos
JeremyAdams2
New Contributor

Similar experience here. rolling back to the October release solves the blank signin window.

0 Kudos
jgfaircloth
New Contributor

Hello @AnthonyLatini ,

I wanted to let you know I tried the latest version of Power Bi (Version: 2.98.683.0 64-bit (October 2021) and the label issue still exist.

Basically, I have a simple layer I am using that has latitude and longitude fields which are used to define the positions of each location. I symbolize the layer with an aircraft icon under the transportation section of the symbol style section of the layer. After, I use the labeling option of the layer and choose the field I would like to use for labels. Next, I define the labeling option to use Arial font and using the color white. Finally, I exit the layer options. All my airplane icons appear on the map and have the labels until I click on anything within the Dashboard that causes the map to refresh. Once the map is refreshed the label section of the layer is turned off and reset. This is based on bring data in from a simple SQL query.  

Do you have an expected time frame for correcting this issue?

Thank you,