Select to view content in your preferred language

ERROR 000464: Cannot get exclusive schema lock. Either being edited or in use by another application or service

03-01-2022 07:02 AM
by Anonymous User
Not applicable

I just upgraded from 2.7 to 2.9 and now every time I run a geoprocessing tool in jupyter notebook (I have python 3.7.11), I get ERROR 000464. I have no instances of pro open and I have restarted over and over. Here is what I am running when it goes wrong and I get the error. It worked fin until  the update, so I'm not sure if I am needing to change something or if it is a bug.


Thank you



m.addDataFromPath(newlocations), "POINT_X_Y_Z_M", '', '', "GEOGCS['GCS_WGS_1984',DATUM['D_WGS_1984',SPHEROID['WGS_1984',6378137.0,298.257223563]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]]")

0 Kudos
3 Replies
MVP Esteemed Contributor

Did you try upgrading to version 2.0?

It recently became available and fixed many bugs.  

Upgrade through conda,

Arcgis ::

or the package manager or

Release v2.0.0 · Esri/arcgis-python-api (

... sort of retired...
0 Kudos
Regular Contributor

Is the data coming from a service, or from a file geodatabase, or from an enterprise gdb...? 

If you open the Catalog Pane and right click your feature class that you are running the tool (in python) against and right click it and select "locks"... does it report any locks? 


Might you have anyone else viewing or editing the same data at the same time, or have a service that is referencing the data?  Just trying to eliminate things can can lock a dataset. 

0 Kudos
New Contributor

Were you ever able to resolve this issue? Did it go away in ArcGIS Pro 3.0?

0 Kudos