Problems with attribute table ArcMap 10.2

4504
4
02-13-2015 03:19 PM
JessicaWhitmore
New Contributor

Hello there everybody, I have run into a problem.

 

I am working with shapefiles and using them as tax parcels for my job.

 

The shapefile is a feature class in a geodatabase, and the issue I am having is that any splits done to the shapefile does not get put in the attribute table properly. If I try to search for it using the attribute table or search for it using the select by features option it will not be found, I have to manually select it from the map itself.  This also happens if I create a feature.

 

I also cannot export the file, if I do export it all the spits that I created disappear and there is no record of them. I will also get a message saying that some features might not have exported correctly.

 

I am wondering if the file got corrupted.

 

Is there a way to fix this?

0 Kudos
4 Replies
VinceAngelo
Esri Esteemed Contributor

It's not clear from your description if you're using a shapefile or a file (or enterprise) geodatabase (a shapefile can't be a "feature class in a geodatabase").  More details, with names of datafiles, exact commands, and with explicit error messages could help spur responses.

Please post questions "In a Place" instead of your personal blog -- this way moderators can move them to a better places if necessary.  You can move this yourself by clicking on the question title and using the "Move..." option in the upper/middle right side "Actions" menu, then choose "Managing Data."

- V

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Hi Jessica,

Try 01

Try Save Edits followed by Stop Editing from Editor toolbar. Then do the stuffs like query in attribute table and export data.

Try 02

It could be a corrupt mxd. Copy the layers from the old mxd. Open a new blank mxd. Paste the layers in the new mxd. Save the mxd.

Let me know your observation.

Thanks,

Jay



Think Location
0 Kudos
DarrenWiens2
MVP Honored Contributor

Have you tried rebuilding the Spatial Index? This solves all kinds of random issues.

0 Kudos
JessicaWhitmore
New Contributor

Thank you guys for all of these suggestions, I won't be back to work until Tuesday.

I will try and work some of these out.

I know that it is something with the parcel shapefile itself because I have put it is multiple mxd's.

This problem has been going on for longer then what I have worked there for, I just happened to catch it.  I will update with actual files and extensions when I return to work.

0 Kudos