Select to view content in your preferred language

Output of 2 joins & a feature class to feature class operation results in null values

11-06-2013 06:27 AM
Regular Contributor
Hi there

I created a model which included creating attribute indexes and 2 attribute joins. This was done in ArcGIS 10sp4. The first two joins were tables in a file geodatabase. The final final was a polyline feature class.

For the final part of the model I tried to find an export function, similar to save data when righting clicking on a layer in the table of contents, as I needed a new fully editable table. I couldn't find the same function so I ended up using the feature class to feature class tool.

After running the model, I looked at the resulting exported feature class, only to find all the fields which were joined to the polyline feature class contained null.

I looked at feature class from which this was copied from and that contained all the additional data from the joins.

Does anyone know what I have done wrong? I expected all the join data to be included when running the feature class to feature class tool, especially as the attribute field headers were brought across.

I then tried the same thing again, this time without using model builder and doing each step myself. For the final stage I just selected 4 rows of data and didn't select Keep All (optional)? and it worked.

Does anyone have any ideas as to what I may have done wrong with my model? If I need to explain things further I can.

The problem I have with the model is that it took 54 minutes to run. Most of that time was spent doing the feature class to feature class stage. There were 6819 records to deal with at this stage, not forgetting the joins that were in place.

Kind regards

0 Kudos
0 Replies