Model Builder Models - 10.1/10.0 compatibility

2512
1
08-22-2012 08:42 AM
AndrewRudin
Occasional Contributor III
Anyone running into problems with compatibility of model builder models between 10.0 and 10.1?  We are in the process of upgrading our power users to 10.1 for testing and I noticed the problem below when trying to work on a new model.

I created a model in an SDE toolbox at 10.1.  When users with 10.0 clients try to browse for it, the toolbox is present, but the model is not visible.  I was looking for a way to downgrade my model, but there is no option for that.

In addition, if I create a model in an SDE using a 10.0 client, and then modify that model with a 10.1 client, the contents of the model are not visible from the 10.0 PC.

So not sure if this is a fluke or by design.
0 Kudos
1 Reply
curtvprice
MVP Esteemed Contributor
There is generally no forward compatibility for ArcGIS documents (mxd,lyr,tbx, for example).

If you want to access toolboxes created or edited in 10.1 using 10.0, you need to save them to previous version.

Arc 10.1 help: Saving toolboxes to earlier versions
0 Kudos