Model Builder doesn't reverse Z values when value is >999

06-16-2012 01:23 PM
New Contributor
I'm using model builder and one of the tools I'm using is to reverse the z values in my polyline dataset (to create negative elevation contours).  [tool name: Adjust 3D Z]

When my dataset contains only z values between 0-999 it works fine.  When my dataset contains at least one value of 1000 or higher, NONE of the z values are reversed.  When my dataset contains only values 1000 or greater, again, NONE of the z values are reversed.

When I run this tool outside of model builder, it works fine.  It takes about 3 minutes for my dataset.

When I run the tool inside model builder, it fails when I have values greater than 999, but it doesn't tell me it fails, when I open the geoprocessing results window it claims to have successfully completed the tool in 8 seconds.

Does anyone know why it doesn't work?  Why it doesn't know that it hasn't worked?  And most importantly, how to fix it?!  Thanks!!
0 Kudos
0 Replies