Select to view content in your preferred language

Error 000229 when trying to Clip

24643
36
07-30-2012 04:20 PM
GIS1
by
New Contributor II
Hi friends,

I am experiencing a weird issue. We have a layer that seems fine. It is visible in our map and we are able to manipulate it in many ways. However, when trying to clip it out given a shapefile, we get the following error:


Error 000229 Cannot open blah blah blah

The ESRI help is not very helpful on this:
http://help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//00vp00000005000229.htm

Obviously, the data exists, we can see it on our map. Furthermore, performing the same clip on a different computer works just fine. It's just this one computer that seems to be experiencing this issue.

Any ideas?

Thanks!
Tags (2)
0 Kudos
36 Replies
ArnoldBijlsma1
New Contributor

I had the same error message when running a Python script containing an Intersect and then a SpatialJoin. I enabled Background Processing in the Geoprocessing Options (no idea why it was off) and suddenly it worked.

0 Kudos
mrmark
by
Occasional Contributor

Thanks tojthompson88 - in my case at least it was fixed by change the way things were named in the Table of Contents (ToC). Specifically, the layers that were failing were in a Group -- with a space in the name. ArcGIS 10.3.1 with 64-bit background geoprocessing on. I use underscores EVERYWHERE but the ToC. Now including the ToC.

A man's feet should be planted in his country, but his eyes should survey the world. - G. Santayana
0 Kudos
TheoFaull
Occasional Contributor III

Be careful there are no lock files on the layer. Sounds like an access issue to me.

0 Kudos
TiffanyPuett
Occasional Contributor II

Tip 1: Don't use shapefiles. File GDB featureclasses are much more reliable and consistent when it comes to editing.

Tip 2: When getting an additional warning that the number of records don't match the number of rows, make a backup copy of the shapefile. Then delete all of the file extensions for the shapfile except the shp, dbf, shx. Copy the dbf to another directory and then add it to a blank ArcMap where you can edit it. Hopefully it will be obvious which records should be deleted. Typically these will be exact duplicates. Delete them both. Then go back to the copy where the shp is and rename the dbf to "<name>_old" then replace with the edited dbf file.

Worked great for me!

0 Kudos
Leandro_AugustoCerno
New Contributor

Same frustrating problem here. Anything tryied. No fix founded

0 Kudos
JakeSimms1
Esri Contributor

Please see this as a possible solution

Error: 000229: Cannot open 

0 Kudos
JamesAmato
New Contributor III

I was having this issue running the Append tool in ArcMap on a feature located in a feature dataset. I ran the tool in ArcCatalog and it worked.

0 Kudos