Select to view content in your preferred language

Error 000229 when trying to Clip

24694
36
07-30-2012 04:20 PM
GIS1
by
New Contributor II
Hi friends,

I am experiencing a weird issue. We have a layer that seems fine. It is visible in our map and we are able to manipulate it in many ways. However, when trying to clip it out given a shapefile, we get the following error:


Error 000229 Cannot open blah blah blah

The ESRI help is not very helpful on this:
http://help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//00vp00000005000229.htm

Obviously, the data exists, we can see it on our map. Furthermore, performing the same clip on a different computer works just fine. It's just this one computer that seems to be experiencing this issue.

Any ideas?

Thanks!
Tags (2)
0 Kudos
36 Replies
GinoMellino
Occasional Contributor

You have helped someone...me! I was getting error 000229 trying to batch merge and buffer 10 or so layers and had tried various work-arounds including removing them from grouplayers but nothing worked. Clicked background processing off and it worked flawlessly. Thank you for posting this!

KeithWright1
New Contributor

Helped me, too. A tip o' the compass to you! I was mystified as to why a simple "clip" would not work, especially since my feature classes were entirely accessible and not grouped. Couldn't figure out what on Geo was going on (of course this is ESRI, and their "help" was anything but...).

Then I read Brendan's post: found and un-selected the "background processing" box, which I had never ticked (but which was ticking me off), and suddenly the clip worked.

DavidCampbell
New Contributor III
I was getting this error in modelbuilder. Trying to dissolve and pass the result on to an add field. It wouldn't pass saying it didn't exist. As my output from the tool I had %value%\Name. The output appeared in its correct file folder but would not pass. After playing around, I tried adding '.shp' to the output name and it passed. Not sure if that is too basic and everyone new that, but just in case....
0 Kudos
MichaelRobinson1
New Contributor III
Same issue.  Trying to Dissolve line SHP file.  Fails with error 000229.
Fails with either Geoprocessing Tab and with Dissolve selected from toolbox
ArcMap 10.2.1, Win 7

No write access issue to folders which seems to be a common problem.

Solution appears to be to move the file out of the group layer(folder) it is in and put in directly under the main layer.
Works fine then.   Not sure what causes this but at least there is a work around for this problem.
0 Kudos
ChrisRobinson
New Contributor III
Receiving this error while trying to field calculate two records in a table by concatenating the letters "HY-" and the object ID into an ID field.  The layer is not in a group, first layer in the TOC and the layer resides in an enterprise geodatabase.  Using ArcGIS desktop 10.2.1.  Have tried removing the layer and re-adding it but did not work.  It did work once I opened up a new arcmap document and pasted the layer there and tried the field calculate. 


Chris
0 Kudos
DavidCampbell
New Contributor III
Ran into this problem again; I have already posted, but I just want to make sure people know....

PUT .SHP TO THE END OF YOUR FILE NAME WHEN CREATING AND THE ERROR GOES AWAY.
0 Kudos
JasonSchroeder
New Contributor
My error was resolved because I was inserting a space into the name of the feature class. I ran some Python to remove the space from my variable and this fixed the issue. I was inserting the values from a field into a variable, and naming the feature class from the variable. Unfortunately, some of the values had spaces in them.

See following thread: http://gis.stackexchange.com/questions/92254/renaming-a-variable-input-to-replace-spaces-with-unders...

It would be nice if ArcGIS would account for this problem - either by automatically inserting underscores for spaces, or by giving an error that makes sense.
0 Kudos
JenniferSexton
New Contributor
I am getting this error from the python window when trying to run MakeFeatureLayer_management.

Running 10.2.1 with windows 7 and oracle11g - was not having this problem on 10.1.

None of the solutions I've seen (which are few) have solved this problem so any information is greatly appreciated.
0 Kudos
AmandaBishop
Occasional Contributor

I am getting the Union Error #000229 - Unable to open source layer

I have tried several solutions to no avail:

1. Copying the datasets to another file location (desktop, shared network drive, etc.)

2. Renaming the geodatabase and the source files

3. Exporting the source files as shapefiles (.shp)

4. Completely restarting a new project and inserting the files and retrying the Union.

NOTHING has worked!  Its ironic because this is simple geoprocessing task that was set up in a tutorial through ESRI.

I have contacted ESRI support and waiting for a call.  I will repost if I get a solution.

0 Kudos
AmandaBishop
Occasional Contributor

To all those who are interested, I have not spoken with ESRI Support yet, but me and my team have come up with a solution to this issue:

Personal geodatabases have been phased out for computers running 64 bit versions of ArcGIS:

http://resources.arcgis.com/en/help/main/10.1/index.html#//00vp0000002t001324

All of the new computers are 64 bit, and a lot of the older CAD/power machines are 64 bit.

The solution is to create File Geodatabases and export the data you need to a shapefile then import it as a feature class to your new file geodatabase.  Go to your project or open Catalog, run the Union tool using the new feature classes (you will have to reset the data source in your project).  Remember to store your output in a separate file geodatabase.  I don't believe the Union tool will allow you to store the output in the same field geodatabase as the feature classes being processed.

Happy GISing!

0 Kudos