Attribute assistant help.

2079
14
04-18-2017 08:58 AM
Highlighted
New Contributor

I am new to Attribute Assistant tool, trying to learn to use in my company, can anyone help me how to set up value method & Value Info in dynamic table. I didn't find much documentation online.

Reply
0 Kudos
14 Replies
Highlighted
MVP Esteemed Contributor

There actually is a ton of info online.  Start here:  Overview - Attribute Assistant | ArcGIS Solutions and then step through the set up, configure dyanamic value table etc.

Or, start here:  Overview - Attribute Assistant | ArcGIS Solutions and take a look at All Methods.

Once you get your feet wet, you'll have specific questions, I'm sure.  Post them as you come up with them.

Best of luck

Highlighted
New Contributor

Joe,thanks for your help, I read all available documents and set some rules in Dynamic table but  none of them are working except last value, can you help me what mistake I am doing here.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Of the methods you show, I've only used the Intersecting_Feature, so I won't be much help with the others.  That said, I do see a few things that are puzzling.

In your Table Name column, I see references to 'dot' names, like Asset.Main_LINE.  I assume this is an enterprise geodatabase feature (SDE)?  If so, drop the Asset. and just go with Main_LINE.  

OID 180 does not reference 'Asset.' so I'm wondering if you are trying to update data that reside in different databases.  Again I can only speculate this is the case.  You can only edit features/tables from one geodatabase at a time.

OID 182 is a complete mystery to me with * as the table name; I've never got the lastvalue method to work for me.

Finally, do you have the log file running?  If so, it can give you an idea what is or isn't going on.  If not, go into the .config file and set logging to <true> and give it a directory path in which to write the log.  I use the same path to the config file for the log file.  I've found the log file to be a great asset for trouble shooting; mmiller-esristaff‌ the ESRI Attribute Assistant go-to guy stressed that to me.

Let me know if you get it going or still have problems...

Highlighted
Esri Regular Contributor

I believe Joe is correct.  Try just the Feature Class name, you do not need to use owner and database.  Same for fields.  

Highlighted
New Contributor

Thanks Joe, it worked!!! Just tried with feature class name.

OID 182 is a complete mystery to me with * as the table name; I've never got the lastvalue method to work for me---"*"means , value applies for all the table, first method it worked for me was Last value.

Michael Miller do you know why this  method is not working. I am trying to split the main when I place the valve feature. Any suggestions?

Reply
0 Kudos
Highlighted
New Contributor II

Hello elvis soto , Joe BorgioneMiller ESRI

My question is concerning the method " INTERSECTING_FEATURE"

why when i select all values they are not matching? But if i do it one by one

the values suceed intersect.

what´s happened and how can fix this?

Thanks 

Regards 

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Sorry I can't offer a solution- perhaps Michael Miller‌ can.  I don't use attribute assistant any more with the release of Attribute Rules.  Anything AA does you can do with Attribute Rules.

Highlighted
Esri Regular Contributor

I am not sure what the issue is.  Could you provide more details?  Turning on the AA Debug log would help too

Highlighted
New Contributor II

First I would like to thank you very much, Michael Miller, as you gave some of your precious time to answer my doubt, wich I never dream that would be you in person to do it, it is really an honor.

I will try to be as explicit as possible: I can´t turn on the debug log, but i will leave here the config file in attachment, which might help. I use the AA version 2019.2.14. and 10.7.1 Desktop.

I am organizing a land registry for a very important entity in my country, and in the following example I intend that
Each row contains is transferred to another row , this work only for 2 selected rows(source and target), but i want to perfom many fields, making possible  to reduce buttons clicks.

1º Process2º Process

 

AA CONFIG FILE

<?xml version="1.0" encoding="iso-8859-1"?>
<!--
| Version 3.1.17
| Copyright 2018 ESRI
|
| Licensed under the Apache License, Version 2.0 (the "License");
| you may not use this file except in compliance with the License.
| You may obtain a copy of the License at
|
| http://www.apache.org/licenses/LICENSE-2.0
|
| Unless required by applicable law or agreed to in writing, software
| distributed under the License is distributed on an "AS IS" BASIS,
| WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
| See the License for the specific language governing permissions and
| limitations under the License.
-->


<configuration>
<Name>Attribute Assistant Release</Name>
<appSettings>

<!--Options for the Attribute Assistant-->
<!--Option to turn on the AA on startup-->
<add key="AttributeAssistant_EnabledOnStartUp" value="True" />
<!--Option to turn on the AA on when editing is started-->
<add key="AttributeAssistant_EnabledOnStartEditing" value="False" />
<!--The name of the table that defines the functions for the Attribute Assistant-->
<add key="AttributeAssistant_TableName" value="DynamicValue" />
<!--The table used for Unique ID Generation-->
<add key="AttributeAssistant_GenerateId_TableName" value="GenerateId" />
<!--Activate the debug mode which writes a log file-->
<add key="AttributeAssistant_Debug" value="false" />
<!--Path to store the log file, do not include the file name. The default location is %USERPROFILE%\ArcGISSolutions -->
<add key="AttributeAssistant_Debug_Path" value="" />
<!--Option to clear the last values between toggling it on and off-->
<add key="AttributeAssistant_ClearLastValue" value="False" />
<!--Option to clear the last value array when you switch a version-->
<add key="AttributeAssistant_ClearLastValueStopEdit" value="False" />

<!--The geocoder used by the AA for the Get_Address rule-->
<add key="Geocoder" value="http://geocode.arcgis.com/arcgis/rest/services/World/GeocodeServer/"/>

<!--Field names in the Generate ID Table-->
<add key="SequenceName" value="SEQNAME"/>
<add key="SequenceCounter" value="SEQCOUNTER"/>
<add key="SequenceInterval" value="SEQINTERV"/>

<!--Option to delete features without AA processing related records. If True, delete operations will be much quicker when AA is enabled.-->
<add key="BypassEditOperationCheck" value="True"/>

<!--Option to call on create instead of On Change Geometry when a line or polygon is split using the Split Tool.-->
<add key="OnCreateWhenSplit" value="False"/>
<!--Option to call a stored procedure for generating the ID seq.-->
<add key="GenerateIDStoreProceName" value=""/>
<!--Option to expose commented on AA prompts.-->
<add key="ShowCommentsOnPrompt" value="False"/>
<!--Option to suppress stored event on all cases, only disable if experiancing issue with the parcel fabric. May case issues with other rules-->
<add key="SetStoreEventsRequired" value="True"/>

</appSettings>

</configuration>

I apologize if there are any english mistakes or not being as explicit as possible

Best regards.

Reply
0 Kudos