ArcGIS 10.5.1 crashes when managing privileges on SDE environment

413
8
10-17-2018 09:23 AM
MollyWatson1
Occasional Contributor

When managing/updating privileges for a feature class in our SDE environment, ArcCatalog 10.5.1 and ArcMap 10.5.1 crashes - regardless of the feature class. The computer has Windows 10 installed. No error message is displayed. The software just crashes and closes. Has anybody experienced this and found a solution?

0 Kudos
8 Replies
Asrujit_SenGupta
MVP Regular Contributor

Same issue while using the "Change Privileges" tool?

Issue on any machine or a specific machine?

Happens with a newly created Feature Class as well?

0 Kudos
MichaelVolz
Esteemed Contributor

What kind of database are you using?

0 Kudos
MollyWatson1
Occasional Contributor

SQL Server

0 Kudos
MichaelVolz
Esteemed Contributor

Do you have all appropriate patches applied for this environment?

Did this issue occur once you upgraded to SDE 10.5.1 or has it taken awhile to see this behavior?

The below thread discusses a patch for your environment.  Just something to test if you have not already done so:

https://community.esri.com/message/711923-re-features-inside-the-enterprise-geodatabase-not-showing-... 

MollyWatson1
Occasional Contributor

The issue occurred once the users upgraded to Windows 10. When they were using ArcGIS 10.5.1 on Windows 7 they did not have the issue. I will take a look at the thread you provided and the patch testing. Thanks!

0 Kudos
MollyWatson1
Occasional Contributor

The users already have the ArcGIS Desktop 10.5.1 SQL Server Permissions Patch installed. Do you think having them remove ArcGIS completely and reinstalling it is a good next move? 

0 Kudos
MollyWatson1
Occasional Contributor

Yes, same issue when changing privileges on a newly created feature class. So far it has only been documented as occurring on 1 machine and 1 user. When using the "change privileges tool", an error of 99999 comes ups "cannot find the user because it does not exist or you do not have permission." I reached out our database manager to see if he can check the permissions of the user. Hopefully that will resolve the problem.

0 Kudos
MollyWatson1
Occasional Contributor

I just received some more information from the user experiencing the issue. The issue also happens with another user on another machine. The issue only happens on their desktop PCs. The laptops running Windows 10 and ArcGIS 10.5 do not experience the issue.

0 Kudos