ArcGIS Web App Builder - IIS

9305
16
06-30-2015 12:49 AM
SaurabhGupta5
Occasional Contributor

Dear Fellows,

I have downloaded the arcgis web app builder and able to  configured properly by using arcgis developer account. Now, everytime i have to execute startup.bat file to load my application. I want to know how can i configure this application into IIS so others can also access and use.

Anyhelp would be greatly appreciated.

Many Thanks!!

Regards

0 Kudos
16 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Saurabh,

  Normally the Web AppBuilder application is intended to be installed on a development machine and the app that is developed and configured is what is intended to be shared on your web server for use by others. But there has been threads discussing setting up WAB on a server for multiple people to use as a shared resources.

Sharing Web AppBuilder apps with multiple users

Is it better to share "application" registered in AGOL between WAB-dev edition developers, or separa...

Web AppBuilder sharing

Rebecca has some great resources/tips for installing WAB as well:

Tips and Observations for getting Web AppBuilder - Developer Edition Installed

RebeccaStrauch__GISP
MVP Esteemed Contributor

Also, to add on to what Robert mentioned, if you are just trying to deploy (a snapshot of) and app for others to see, and not expecting for them to be able to edit or see immediate changed (without redeploying), check out

Deploy app—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

SaurabhGupta5
Occasional Contributor

Thanks Rebecca and Robert  for your quick reply. But i feel rebecca answer is more closer to what i want.

Let me narrow down my problem further:

I only want to deploy my configured app to IIS server not complete app builder and while mapping following path in IIS (D:\XXX\iPLAN_Code\arcgis-web-appbuilder-1.1\client\stemapp)

and browsing on port 80 via http://localhost/iPLANII/index.html

I am getting attached error. Is there a real need to configure proxy also before publishing it to IIS as stated in rebecca reply. Please confirmappbuilder.JPG

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Saurabh,

   So it look like you have a pathing problem as the errors you show all are trying to access http://localhost/http://localhost/....

No you do not have to setup a proxy, but it will definitely help when any of your requests exceed the url limit and need to use post (this happens a lot when buffering and other large geometry operations).

Deploying the app to IIS is pretty straight forward.

  1. After you have downloaded the app from WAB using the WAB Home page and clicking the triple ellipses and choose download, you will get a zip file.
  2. Unzip this zip file to a known location (I do not like to put the files directly in the inetpub\wwwroot folder as this folder requires Administrator access to edit). I normally use a www folder on the root of my c drive  (c:\www\MywabApp1).
  3. Once I have unzipped the website files to (c:\www\MywabApp1), I now open IIS and expand the tree in the connections window until I see the Default Web Site, then I right click on the Default Web Site and choose "Add Application"
  4. I enter my sites alias "MyWABApp1" (or in your case iPLANII) and then in the Physical path I browse to "c:\www\MywabApp1".
  5. I then click the "Connect as..." and choose Specific user and click set and add credentials.
  6. I next click "Test Settings..." and verify Authentication and Authorization.
  7. Click OK to complete the Add Application dialog
  8. I now enter the website url "http://gislap183/MyWABApp1/​" in my browser and it brings up the WAB site.
  9. My last step is to open the config.json file from the c:\www\MywabApp1 folder and use by JS IDE (Brackets) to "beautify" the json and then add my proxy url.
SaurabhGupta5
Occasional Contributor

Hi Robert,

Though i have followed the same steps , still i am facing same error only. Only i am not using 'connect as ' because i am having admin rights on my system. Also, not configuring the proxy.

It's really annoying why it is not working ?

I have also tried mapping path  to IIS i.e. D:\arcgis-web-appbuilder-1.1\client\stemapp but no success.

Please suggest something

Regards

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Saurabh,

   That you tested that you have IIS functioning correctly? Have you tried just the localhost as the url in your browser and gotten the welcome to iis page?

I am a admin of my whole network and I still use connect as in iis. Did you use the "Test Settings... and get both tests to pass without using the connect as?

Your test of using D:\arcgis-web-appbuilder-1.1\client\stemapp should have FAILED with just the loader screen (blue screen) with white progress bar in middle on going so far. This is because the stemapp site does not have its env.js setup correctly yet. You have to setup an app that has been "Downloaded" as instructed in the steps of my previous post.

As you have yet to get a WAB app properly deployed I would advise that you open WAB using the bat file and create a new app then follow my EXACT steps and see if you can get a site to deploy properly. Lots of people are getting WAB apps deployed on IIS so it has to be something you are doing or something in your deployment environment.

SaurabhGupta5
Occasional Contributor

Hi Robert,

Yes, my iis is working fine.

I will try creating new application and than let you know . Thanks for your advice.

Also, one doubt in my mind , may be this question is irrelevant but just for the sake of knowledge. I can see  env.js exist in stemapp folder and that too similar to the one downloaded via app. So what's the difference setting up from this folder or after downloading?

Thanks Again

0 Kudos
AndrewParnell
New Contributor II

Hi Robert,

Thanks again for these tips.

Could you clarify Step 9:

     My last step is to open the config.json file from the c:\www\MywabApp1 folder and use by JS IDE (Brackets) to      "beautify" the json and then add my proxy url.

What should I be adding as my proxy URL?

Many thanks,

Andrew

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Andrew,

   Use the url of the proxy that you have downloaded form ESRIs proxy resource page and have deployed to your web server.