11-23-2020 09:03 AM
Occasional Contributor


These are the details of my system:

ArcGIS Enterprise 10.8.1, ArcGIS Pro 2.6.3, Electric Utility Network 4 and SQL Server 2018.

While running a connected trace I am getting an error message indicating that "dirty areas were discovered" followed by a list of ElectricJunction GUIDs. When I try to validate the topology I get a message saying that "no dirty areas found" and the attribute table of the dirty area layer is empty (see image below)

When I check the modify association pane for the items in the trace error message, the electric attachment items are highlighted in pink, but other items attached to the pole don't show this highlight. I used a group template, with the corresponding attachment association, to add create: the poles, the electric lines, the electric attachments; but the street light or flood lights are added with an attribute rule. Deleting the highlighted attachment association, manually creating it again and validating the topology again removes the highlight from the attachment association (see image below)

Here are my questions/concerns:

1- Why the dirty area table and the topology validation doesn't see the problem with this attachment associations and it's only through a trace that the error is uncovered. Also, the trace error doesn't list all the items with this problem. After running the trace and fixing the association of the items listed in the error message, I find my self with a new list of items when I run the trace again. I have run the trace 10 times now and every time I get a new list of ElectricJunction items with problems.

2- I have used this group template before and after the edits in the section presenting the this problem and those other circuits don't show this problem. Why this happened when I haven't changed my workflow or group template?

3- How can I identify and correct all these problematic attachment association without having to recreating them manually one by one? I have 2 other circuits that are showing the same error when I run the same connected trace. This could me that there could be more than a 100 association with this problem. Can Arcade or ArcPy can be used to identify and correct this association?







0 Kudos
2 Replies
by Anonymous User
Not applicable

Hi @Billy 

have you had a look to see if there are any Subnetworks part of that "pole" some time the dirty areas can be there? there should be a layer that you can switch on to viably see the Dirty areas.

You can access the attribute pane and have a look at the error and do more research.

0 Kudos
Occasional Contributor

Hi Keiren,

The subtnetworks were not created at the point. I was able to eliminate the errors by recreating all the associations, but I couldn't determine the reason why this happened.

Thanks for the reply.

0 Kudos