webform issue after After Survey 123 September 2021 update: Create web form' enabled. Error: Missing .webform file

6511
34
Jump to solution
09-24-2021 05:49 AM
WetherbeeDorshow
New Contributor III

Since the September 16 update, several surveys no longer work in the webform, even after rebuilding and republishing the survey using the latest version of Survey 123 Connect.

We get this error - 

This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file.

Press here to try to open this survey in Survey123 field app (installation required).

Interestingly, when I look at the webform that gets created successfully during the publishing process, the content of the .webform file is as follows:

{
"error": {
"code": -1,
"details": [],
"message": "Error: [object Object]"
},
"success": false
}

 

This issue appeared immediately after the September 16th update, prior to any efforts to republish or change the form.

Thanks!

34 Replies
RainbowUnicorn
New Contributor III

 Hey @MJBiazar,

1. I'm working in AGOL hosted on ESRI servers.  My org doesn't have an enterprise environment.

2. Yes.  I made some minor tweaks to an existing template that I downloaded (changed list of values, toggled required field, changed some alt text fields and color palettes) and then attempted to republish.  Used this template: https://survey123.arcgis.com/surveys/templates/1f406376218247eebffe5057ac01073b

3. I haven't tried to publish a copy of the survey yet.  I'll give that a shot next.  

I'm hesitant to download the XLS form because the last survey I authored got completely jacked-up and wouldn't work at all when I tried to download it.  Also - I can only use Survey123 desktop on my personal machine as the application apparently isn't authorized on my work machine.  

Thanks for the response/help,

Amilynn

 

0 Kudos
RainbowUnicorn
New Contributor III

Just saved a copy and tried to republish.  Got this error, which is the first one I got during the first iteration of attempting to publish it.  Thinking I might open a support ticket as this isn't the first time Survey123 in the browser hasn't "behaved" in my environment.

RainbowUnicorn_0-1657045282667.png

 

 

0 Kudos
MJBiazar
Esri Contributor

@RainbowUnicorn I'm sorry to hear that you are experiencing a different issue while trying to publish a copy of your survey (you may find this post helpful). Whatever is causing this issue may be related to the issues you were experiencing with your original survey. I think at this point it's best for you to create a case with Esri Technical Support to take a closer look at your issue and continue troubleshooting. 

0 Kudos
RainbowUnicorn
New Contributor III

@MJBiazar - Just a quick update...I quit trying to edit the form on my work computer.  I went and started working on it on my personal computer (which is unfortunately common practice due to frequent issues with ESRI application functionality on our work network) and surprise, surprise!  No problems, everything worked just fine.   

Thanks for your attention/assistance, but I think we can safely assume the issue lives in IT.

0 Kudos
MJBiazar
Esri Contributor

@RainbowUnicorn Fantastic! I'm glad that you are not experiencing the issue on your personal computer. I agree with your assessment as well. The issue seems to be specific to your work environment (the machine, network, etc.)

0 Kudos