webform issue after After Survey 123 September 2021 update: Create web form' enabled. Error: Missing .webform file

2744
33
Jump to solution
09-24-2021 05:49 AM
WetherbeeDorshow
New Contributor III

Since the September 16 update, several surveys no longer work in the webform, even after rebuilding and republishing the survey using the latest version of Survey 123 Connect.

We get this error - 

This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file.

Press here to try to open this survey in Survey123 field app (installation required).

Interestingly, when I look at the webform that gets created successfully during the publishing process, the content of the .webform file is as follows:

{
"error": {
"code": -1,
"details": [],
"message": "Error: [object Object]"
},
"success": false
}

 

This issue appeared immediately after the September 16th update, prior to any efforts to republish or change the form.

Thanks!

33 Replies
HaroldHerrera1
Occasional Contributor

Yes, we are using external choices.

by Anonymous User
Not applicable

I am experiencing the same issue and have external choices. I am trying to upgrade the Esri Damage Assessment solution surveys from their ancient xls formats and republish them as new surveys to correct several issues with the original surveys in the solution.

WetherbeeDorshow
New Contributor III

No, we were not using external choices in the survey. 

MJBiazar
Esri Contributor

@HaroldHerrera1 @FionaBarry  Thanks for the confirmation! Having external_choice questions seams to be the cause of the error. A defect has been logged against this behavior by Esri Technical Support and will be reviewed soon to determine the best actions to address this issue.

YuliaMamonova
Occasional Contributor III

Hello, do you have any updates on this? Having the same issue.

0 Kudos
MadelaineTaftFerguson
New Contributor II

Ditto. Is there a bug we can follow / somewhere to see updates?

MJBiazar
Esri Contributor

Here is the details for the defect:
BUG-000144749 - Survey with external select published from Survey123 Connect cannot be accessed in web app returning an error "This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file."

OlivierDemars1
New Contributor III

Looking forward to a quick resolution as this is also impacting our surveys.

Thanks

YuliaMamonova
Occasional Contributor III

Just so everyone is aware - Esri technical support refused to share the link to download Survey123 connect 3.11 version and suggested 2 options:

1. to ask other community members to send me the link

2. to ask my colleagues if someone still has 3.11 version

This is an extreme level of support from Esri, 5 stars!

Please let me know if you guys found any workarounds other than removing external choices or using 3.11 Connect. 

OR

If you have 3.11 version for Mac OS, please share it with me at yulia.mamonova@ceresenv.com

THANK YOU!

by Anonymous User
Not applicable

No work around yet...

Quick, everyone check your downloads folders on all computers for previous versions. We also need to start a repository of old versions of software for emergencies like this.