Survey 123 {"code":-1,"message":""}

1808
7
02-10-2020 08:34 AM
DaveSelvidge
New Contributor III

I'm attempting to create and publish a survey through Survey123 and upon completing a test version of the new survey, I attempt to publish it and I get the following error code with no further explanation:

{"code":-1,"message":""}

After searching google and geonet, I wasn't able to come up with what exactly this error means. All of the other examples of errors like this that I have seen have additional information in the error code( for example: {"code":-1,"message":"","isTrusted":true} . 

I have tried the following solutions but still get the same error:

 - Reload the webpage

-  try in a different browser

-  sign out and then sign back in 

-  restart the computer

*UPDATE* - I deleted the problem survey and started back over from scratch and I was able to publish the survey. However, I'm still curious to see if anyone knows why it failed in the first place and what that seemingly non-descriptive error code actually means so that I can avoid it in the future. 

7 Replies
AprilChipman
Occasional Contributor III

I'm getting this same error when I'm trying to create a webhook.

0 Kudos
MJBiazar
Esri Contributor

Hi Dave Selvidge‌,

Check out this article (Error: Unable to create a new survey. {"code":-1,"message":"","isTrusted":true} ) might help. 

Also, have you ever transferred the ownership of this survey? Because, if you change the owner of the survey's items but do not move them to a folder with the exact same name, you will get this error message when trying to make any changes to the survey. That's because while you own the survey and are capable of editing and technically re-publishing, Survey123 cannot connect to AGOL to access the underlying data to republish the survey because of the missing folder. 

Let me know if this resolves the issue for you.

Best,

MJ

0 Kudos
DallasClements
New Contributor

I am also getting the same error when I make changes to some of my forms. I haven't identified a pattern on why it effects some of my forms and not others. 

0 Kudos
IsmaelChivite
Esri Notable Contributor

Please report these issues via Esri Technical Support so we can look at your surveys in more detail.

Could you please try the following?

* Go into the survey gallery and use the save as option to create a clone of your survey

* Then publish your copy of the survey

Does it work?

JarekHaverluk
New Contributor

This worked great! Thank you Ismael

0 Kudos
JohnGargiulo
New Contributor III

I am new to Survey123 and ran into this issue. I created a decent sized survey and it published fine. Then did quite a bit of editing to the original survey. Deleted questions, added questions and tried to republish.  Ran into this very non-descript error (honestly I get very frustrated with the lack of detail in Portal error messages).  I saved an alternate copy using Ismael's suggestion on this same post but was still getting same error.  Finally, I cleared my cache and attempted to republish and it worked for both the original and the cloned survey!  I hope this post can help avoid rebuilds for someone in the future.  

0 Kudos
DavidJeffers1
New Contributor II

Having created a survey, I then made a copy using Save As and replaced two questions with new answer formats. When publishing this updated survey, I encountered this message. Ismael's workaround did the trick.

0 Kudos