TypeError Cannot read properties of null (reading current version

15126
16
Jump to solution
10-04-2021 10:39 AM
RafaelCelaya
New Contributor
Hello my name is Ralph has anyone seen this error before? It happens when I enter a filter. An error occurred while applying the filter. TypeError: Cannot read properties of null (reading 'currentVersion')
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @RafaelCelaya

If you are applying a filter to a field in a repeat we have an issue logged regarding this error. We are working on a fix for the issue, in the meantime please feel free to reach out to Esri Technical Support and have them attach you to BUG-000143323 to track progress on the issue. 

Thank you,
Zach

View solution in original post

16 Replies
ZacharySutherby
Esri Regular Contributor

Hello @RafaelCelaya

If you are applying a filter to a field in a repeat we have an issue logged regarding this error. We are working on a fix for the issue, in the meantime please feel free to reach out to Esri Technical Support and have them attach you to BUG-000143323 to track progress on the issue. 

Thank you,
Zach
RafaelCelaya
New Contributor

Thank you Sir, I will reach out to Eris Technical Support.  

0 Kudos
by Anonymous User
Not applicable

I am also having this issue when trying to filter by related data within Survey123. Does anyone know if there has been any update on this?

FredMitchell
New Contributor III

I am also getting this error trying to filter data in Survey123 but not in a repeat. TypeError: Cannot read properties of null (reading 'currentVersion'). @ZacharySutherby are there any updates on this?

0 Kudos
MarkGambordella
New Contributor III

just wondering if you found a workaround.  I am trying to pull out only the First Attachment from a survey123 form to show in a popup and get the same error

 

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello @RafaelCelaya @Anonymous User @FredMitchell

We have a fix for this issue in plan for our 3.13 October update, the fix is currently on our survey123beta website. If we may ask, please test on https://survey1232beta.arcgis.com and let us know if the behavior is still present there. 

Thank you,
Zach
by Anonymous User
Not applicable

I cannot access this webpage... it gives the response :"Hmmm… can't reach this page".

FredMitchell
New Contributor III

There's a typo in the link from Zach...remove the 2 before beta and it will work!

by Anonymous User
Not applicable

It works great! 

0 Kudos