problems when publishing survey on survey123 ||| problemas a la hora de publicar encuesta en survey123

488
2
03-08-2022 12:57 AM
JavierCMartínezPrieto
Occasional Contributor

hello everyone,

I have a problem when I post a survey123 survey.
When I publish it everything goes fine until the end that does not complete, also when I go to the arcgis web page, the form file has been uploaded without problem, but the layer (feature layer) appears to me that it has not been uploaded correctly although the updated data appears to me.
I attach an image to make the problem clearer:

JavierCMartnezPrieto_0-1646729762036.png

it can be seen that the form is dated March 8 while the layer is dated March 3.

I have the feeling that this could become a problem if I continue publishing the data in this way.
I have already tried with different internet connections and with different terminals and the problem persists.

thanks to all of you who participate.

Greetings Javier

#######################ESPAÑOL#################################

hola todos,

tengo un problema cuando publico una encuesta de survey123.
cuando lo publico va todo bien hasta al final que no termina de completarse, además cuando voy a la pagina web de arcgis, el archivo form se ha subido sin problema, pero la capa (feature layer) me aparece que no se ha subido correctamente aunque si me aparecen los datos actualizados.
adjunto imagen para que se vea mas claro el problema:

JavierCMartnezPrieto_1-1646729766590.png

se observa que el form es del 8 de marzo mientras que la capa es del día 3 de marzo

me da la sensación que este puede convertirse en un problema si sigo publicando los datos de esta manera.
alguien sabe que puede estar pasando, ya he probado con diferentes conexiones de internet y con diferentes terminales y el problema persiste.

gracias a todos los que participéis.

Saludos Javier

 

Javier C. Martinez Prieto
0 Kudos
2 Replies
AliciaShyu
Occasional Contributor

If you can see new data been added to the feature layer, then your survey was published correctly.

I believe the modified date on the feature layer is the date you created/uploaded the feature layer to portal or AGOL or updated the schema of the feature layer NOT when the data is written to the feature layer.

 

In the example below you can see that the feature layer modified date is different from the form modified date. This is a survey we currently have in production, I created a web map and web app to show the progress of the data collection efforts and we haven't had any issues.

 

Survey123Inspection.jpg

#######################ESPAÑOL#################################

Si podes ver que se agregaron nuevos datos en la capa (feature layer), entonces la encuesta se publico correctamente. 

Creo que la fecha de modification en la capa es la fecha en que la capa fue creada/cargada en Portal o AGOL o cuando se actualizo el esquema de la capa NO cuando los datos se escriben en la capa.

En el siguiente ejemplo, podes ver que la fecha de modificacion de la capa es diferente de la fecha de la encuesta (form). Esta es una encuesta que actualmente tenemos en produccion, cree un mapa web y una application web para ver el progreso de recopilacion de datos y no hemos tenido ningun problema. 

Survey123Inspection.jpgEspero que tu ingles sea mejor que mi castellano 🙂

 

0 Kudos
JavierCMartínezPrieto
Occasional Contributor

buenas tardes 

gracias por contestar, en mi caso cada vez que publico una capa se me actualizan tanto la capa como el form, cuando esto no ocurre suelo tener problemas con los archivos y datos que se pierden.

adjunto foto para que se mas claro, la encuesta se creo en diciembre y se han realizado numerosas actualizaciones con sus propias publicaciones y los archivos form y feature layer siempre me han ido en concordancia.

JavierCMartnezPrieto_0-1646752787246.png

 

descubrí cual es el error y es que esa encuesta contiene mas 700 fotos en la carpeta media y a partir de las 500 no se porque no se publica correctamente.

Saludos Javier

Javier C. Martinez Prieto
0 Kudos