Passing attributes from Field Maps to Survey123 - Help with URL Encoding

1314
2
Jump to solution
06-07-2022 01:00 AM
GrahamStobie1
New Contributor III

Hi

I'm trying to use a URL link in a Field Maps feature pop-up to open a survey123 form and populate a few attributes. It's working fine when I test using the AGOL map to open the desktop verion of survey123, but doesn't work properly for one of the attributes when using the Field Maps app to open the Survey123 app on my IOS device. 

The attribute I'm having issues with has spaces and an '&' in the values and I know this is causing the issue, so I've tried URL encoding but can't get it to work...any help would be greatly appreciated.

My basic URL (with the itemID replaced with 'xxx') is:

arcgis-survey123://?itemID=xxx&field:FieldA={FieldA}&field:FieldB={FieldB}

 

Field B is the one with the values causing me an issue - it has values like 'Egg & Chips' in it. 

When I try using the URL above I get the value 'Egg' in my Survey123 form - missing off anything from the first space.

I've tried encoding it with the following:

arcgis-survey123://?itemID=xxx&field%3AFieldA=%7BFieldA%7D%26field%3AFieldB=%7BFieldB%7D

 

And I now get '{FieldB}' in my survey123 form rather than hte actual attribute value. Can anyone tell me what I'm doing wrong?

Thanks!

Graham

 

0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @GrahamStobie1

I would suggest using Arcade to encode the URL parameters. Please see this Esri Community blog for more information on how to use Arcade to encode the parameters. 

Thank you,
Zach

View solution in original post

2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @GrahamStobie1

I would suggest using Arcade to encode the URL parameters. Please see this Esri Community blog for more information on how to use Arcade to encode the parameters. 

Thank you,
Zach
GrahamStobie1
New Contributor III

Thanks Zach, I'd missed that blog - really useful, I've got it working now!

0 Kudos