Camera is not available in

243
10
12-19-2019 01:52 PM
Highlighted
New Contributor III

Hello,
I created a form based on a point feature layer representing inspections on the state of snow removal to complete the survey. To complete the investigation, the field agent must select the point to modify and complete the survey. Everything works well, but when he tries to use the camera to take photos, it is not available in edit mode in the InBox tab. Bellow see attachment for the issue.

When I created the form I set up the camera which is available in the Collect tab form.

Any clues regarding this issue would be appreciated.

Regards,

Reply
0 Kudos
10 Replies
Highlighted
Esri Contributor

Hi Tahir,

 

Editing of attachments (photos) are not supported via the Inbox. This means if you open an existing survey via the Inbox, and have an image question in the parent layer, you will not be able to add a new photo. You can however put your image questions inside a repeat, and via that method you can add new photos to an existing parent record, by adding new repeat records with attachments. 

This functionality has also been requested by other users. I encourage you to submit an enhancement request via Esri Support. The support team will assign an official enhancement number for your records and attach it to the previous request. This helps us assess demand for the enhancement and prioritize it accordingly.

Brett

Highlighted
New Contributor III

Hello Brett,

Thank you for your reply. You have just confirmed my doubt on this issue. In reality, the modifications of the inspection points via the Inbox tab make it possible to complete the answers to the questions via the form module and actually in my case I had implemented the begin repeat and end repeat function to allow the recurrence of inspections on the same point. So, I just modified the form and add the camera in the begin repeat and end repeat block and it works.

However, it seems obvious to ask for an improvement to introduce this functionality in Edit mode in the InBox. I will do it on my side to give more chance to see this addition in the next versions.
Thank you!

Regards,

Highlighted
by
New Contributor III

Hello Tahir, 

Could you share more detail how you could create the repeat with the same point? I also had the same issue- not able to attach any images/audio through inbox.

cheers, 

Reply
0 Kudos
Highlighted
New Contributor III

Hello Jay,

All your selected data type variables should be inside the begin repeat and end repeat statement. See attach below is the Excel sheet I configured to display the camera in the form. You should be able to attach your images and audios.

Regards,

Reply
0 Kudos
Highlighted
by
New Contributor III

Hello Brett, 

Could you please provide more information on the alternative way? I published feature layer without any related tables (except for the attachments). Should I add relational table in the original data and then republish it? I've just posted a similar question from Tahir's today.

https://community.esri.com/thread/246804-no-imageaudio-capture-is-activated-when-i-start-survey-from... 

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Jay,

I have just replied to your new post on this topic. This Geonet post gives some more information.

Brett

Reply
0 Kudos
Highlighted
New Contributor III

Hi Jay,

Have you finally succeeded to display your images and audio in your form with the method which I attached in my answer with the example illustrated by the screenshot attached in my answer to your post yesterday?

Regards,

Reply
0 Kudos
Highlighted
by
New Contributor III

Hello Tahir, 

I tried, but got an error when I tried to publish it. This is the error message. I am wondering I could not add repeat because my feature layer is already published without related tables defined? I will check Brett's suggestion, too. I will give you an update when I successfully use camera& audio through Inbox.

Cheers,

Reply
0 Kudos
Highlighted
New Contributor III

Hello Jay,

I got the same error message when I published the first time my form without creating a related table because the begin repeat and end repeat statement cannot be handled without relational tables i.e one to many relation. You don't have choice, for this to work you must define a related table as a feature layer in AOL. In my case I used GlobalID as Primary key to to relate the geometry point table and the inspection table and republish the feature layer to ArcGIS Online Organizational account as a service. When you build your survey form using a feature layer you should be able to set your form using the repeat statement to display your images and audios in Survey 123 built-in form..

Hope this help...

Cheers,

Reply
0 Kudos