Quick Capture Records not Sending anymore

240
4
Jump to solution
09-23-2021 09:58 AM
Labels (1)
KendellRyan1
New Contributor III

Hi,

I have scoured the posts on here and found a few similar sounding issues, but nothing has fixed the problem.  I had hope for this thread , but the suggested solution didn't help.

 
Situation: We've been using QC for several months and just within the last few weeks several of the users have had records fail to send.  There is no error message, it just hangs like it's trying to send and nothing happens.  Similar to the above post it's just frozen.  There is nothing that pops up giving the option to email the data (i.e. the dialog box outlined in this post does not appear).  We've completely closed and opened the app, made sure to be connected to a solid network and nothing.  These are line records following the users hikes/drives, etc.  

This is causing a major issue, so I'm hoping there is something else to try. 

0 Kudos
1 Solution

Accepted Solutions
Mandy_Li
Esri Contributor

@KendellRyan1 First we could try to check if the refresh token is expired - when the refresh token is expired and the user is still in the project, the user can still press the send button, but nothing happens. To rule this out, you can close the project and go back to 'My workspace' page, click the user thumbnail, and see if there's a warning message to ask you to re-enter your password. 

If this doesn't help, we will need to check the app's logging to see what went wrong. To enable logging, go to the app menu again, press the hold the About option for 6 seconds until the Reset option shows up. Now click the Settings option, scroll down, switch on Logging. You will notice a floating icon shows up now, that's where the logging info is stored. Now you can repeat the workflow you described in the issue and try to send the records again from your device. If it fails again, click on the floating icon and check the 'Upload' tab. Take a screenshot and send it to us (or if anything went wrong, messages will show as red on this page now). 

Let me know if you find anything.

View solution in original post

0 Kudos
4 Replies
PaulDoherty2
Occasional Contributor III

I cannot confirm but this sounds similar to an issue we (+ @JaredDoke)  hit when copying layer and project templates from one organization to another.


Can you try checking off/on "optimize drawing"? 

https://doc.arcgis.com/en/arcgis-online/manage-data/manage-hosted-feature-layers.htm#ESRI_SECTION1_7... 

It is probably best to put in an Esri Support ticket to be sure, but I hope this helps!

@Mandy_Li any other ideas?

0 Kudos
Mandy_Li
Esri Contributor

@KendellRyan1 First we could try to check if the refresh token is expired - when the refresh token is expired and the user is still in the project, the user can still press the send button, but nothing happens. To rule this out, you can close the project and go back to 'My workspace' page, click the user thumbnail, and see if there's a warning message to ask you to re-enter your password. 

If this doesn't help, we will need to check the app's logging to see what went wrong. To enable logging, go to the app menu again, press the hold the About option for 6 seconds until the Reset option shows up. Now click the Settings option, scroll down, switch on Logging. You will notice a floating icon shows up now, that's where the logging info is stored. Now you can repeat the workflow you described in the issue and try to send the records again from your device. If it fails again, click on the floating icon and check the 'Upload' tab. Take a screenshot and send it to us (or if anything went wrong, messages will show as red on this page now). 

Let me know if you find anything.

View solution in original post

0 Kudos
KendellRyan1
New Contributor III

@Mandy_Li  , great news, it was the refresh token!  So thank you for that!  I will save this as I can see the logging option being useful in the future.  

0 Kudos
KendellRyan1
New Contributor III

Thank you @PaulDoherty2  and @Mandy_Li .  I am getting my hands on one of the phones tomorrow, so this gives me something to work with which. I will report back.  

0 Kudos