Duplicate records from Quick Capture

359
10
Jump to solution
04-15-2020 04:31 AM
AdministrátorJihlava
New Contributor III

Hello, we're still having troubles with quick capture. It sometimes sends duplicate values within 2-3 seconds. It just captures one incident twice, with completely same values, but created_date differs by 2-3 sec (user sends it from device just once). Does anyone know what can it be caused by? Thanks for your help.  Jane

Reply
0 Kudos
1 Solution

Accepted Solutions
JohnathanHasthorpe
Esri Regular Contributor

Hi Kathy - The hotfix has been released in the stores now.

View solution in original post

Reply
0 Kudos
10 Replies
JohnathanHasthorpe
Esri Regular Contributor

Hi Jane

Can you provide some more info on this:

- What platform are you using to run the app?

- How are you connecting to the internet (4G - Wifi) and does this change?

- What is the autosend interval set to? Or are the users sending manually?

- Do the features have attachments?

- How regularly are you seeing this issue?

It is possible that a feature is sent twice if the app does not get a successful response from ArcGIS when it uploads a feature. This can happen when network connectivity is patchy and the user is on the edge of network/wifi coverage.

I'm happy to work with you to investigate this further if this does not sound to be the cause.

Thanks

John

Reply
0 Kudos
AdministrátorJihlava
New Contributor III

Hi, 

  • we run the app on ArcGIS Enterprise (version 10.7.1)
  • the users are connected via 4G (and I hope it is not changing, but it is possible that they have turned on the wifi connection too on their devices and when they are in touch with wifi signal the device can switch the connection from 4G to wifi - we need to realize it)
  • autosend interval is se to 30 sec. Sometimes users just update a location of captured feature
  • features have attachments
  • we're seeing these issues from time to time (2-3x a week - we usually have 10-20 records per day). Now it happend two days in a row. 

I hope we have stable 4G connection within the city, while the officers are moving just around the city. But of course I can't say this with 100% certainty. 

Thanks a lot for your help. With captured data we have connected subsequent agenda so it is important to us not to have unnecessary duplicities in data. 

Thanks 

Jane

Reply
0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Thanks for the info, can you drop me an email on jhasthorpe@esri.com. I'd like to see whether we could get some logs captured. Thanks John

Reply
0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

We have a fix for this available on EAC: Welcome to our Customer Validation site. 

Please test out build 1.6.91. We plan to release a 1.6 hotfix for this in the coming weeks.

KevinWeston
New Contributor

I am having this exact same issue with quick capture.  The points with pictures are sending two points for each entry.  One of the points contains the attachment and the other point contains all the data without a picture.

Reply
0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

We will be releasing 1.6.103 later this week. This will have the fix for this issue.

You will need to get the updated from the store.

Reply
0 Kudos
kmsmikrud
Occasional Contributor III

We are also experiencing the duplicate records and are currently conducting aerial surveys using the app. I just checked to see if the latest release was out but don't see it. Do you have a date for when it will be released?

Reply
0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Kathy - The hotfix has been released in the stores now.

View solution in original post

Reply
0 Kudos
kmsmikrud
Occasional Contributor III

Thanks Jonathon! We've downloaded the update and hopeful it will fix the repeats. It looks like besides the repeat issue we also had some sync duplicates. We are working offline and so it looks like there are multiple CreationDates for some of the points as well. When the surveyor is syncing there likely isn't the best internet connection so maybe the points tried to sync a couple of times is all we can figure since they are the same geometry/fix time. I'm so glad we lucked out on the timing for this hotfix.

Thanks, Kathy