Values doesn't fall within Domain: ??????

2226
5
06-06-2019 09:57 AM
APaulsen
Occasional Contributor

I am trying to edit values within tables with ArcGIS Pro that was populated by our consultants.  I am getting these values do not fall within Domain errors and will not allow me to make changes to the incorrect data.  What is causing this and how do I fix it?

Tags (1)
5 Replies
KoryKramer
Community Moderator

Hover over the field header you're trying to edit in the attribute table

Based on the error, it should indicate that the domain is Owner, right?

So then if you right-click the FC > Design > Domains

You should be able to see valid values for that domain.

Does that help?

APaulsen
Occasional Contributor

It was an error with the domain in a different field.  If that field has an error it won't let me change or edit anything else within that feature. 

0 Kudos
JayHodny
Regular Contributor

Today I started getting the same error in a feature service from the Election Management solution, I have been populating (using Load Data from the Deployment Tool) in Pro version 2.3.3.  I upgraded to version 2.4 and the issue went away.

PeterMilenkovic
New Contributor III

The error is caused because pro is expecting a domain value, you can solve this problem by setting a default value for field or make the field nullable.

If a field uses a subtype the you need to set a default value for all subtypes or make them nullable

Hope this helps

JamalNUMAN
Esteemed Contributor

Thanks Peter.

 

Right. I got the same error (Failed to create new feature: Value doesn’t fall within the domain: D1) and resolved as a default value for the subtype is added

 

Clip_608.jpgClip_609.jpg

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
0 Kudos