Transfer Attributes now available but not working

03-02-2021 11:50 PM
Labels (1)
New Contributor II

Transfer Attribute Tool is now available but it seems not working or I maybe missing something.

It seems pretty straightforward but it simply not transferring although message "Attribute transfer completed"


I have tried Saving Edits ( included when u save d project ), re-open the Table, re-open the project but nothing happens.

Went back to the good old ArcMap, done , straight away the open table view is updated .



9 Replies
New Contributor II

The tool has been implemented different than in ArcMap.

Once you have applied your Field Mapping Settings from the Editor Settings burger button, follow the informational notifications on the tool to select the source and target features on the map -


Please note that to transfer geometry, you need to match the Shape fields of the source and target layers in Field Mapping -


In ArcMap, this was implemented by checking the 'Transfer Geometry' box.

Esri has also added a Help button that links to online help resources on all Editing tools.


I hope this helps.

0 Kudos
New Contributor

I am experiencing this same issue. I have all attributes linked correctly and follow the prompts as directed. It shows attribute transfer completed and still in my table no attributes have been transferred. 

New Contributor III

Having this same problem- and in Arcmap (if it was points overlapping) it respected the order of target and source. I got my stuff to work by turning off my target> clicking the transfer tool and the source point> turning my target point back on and clicking. It doesn't look like the tool recognizes the order if the features are overlapping. Maybe this is isolated to points- but I wonder why this is happening and what I can do about it? 

Occasional Contributor

@BrookeAumann hit the head on the nail. Can we get this fixed? 

New Contributor III

Same issue here, extra Kudos for workaround @BrookeAumann And could workarounds like this be mentioned in the help?

I tried if it worked changing the layer order. It didn't but it has effect. When getting source features the source has to be on top or the target should be switched off if it is on top.

0 Kudos
New Contributor II

I was pretty frustrated with this tool in Pro. Settings all seemed correct. Target feature set as editable and selectable. Source feature set as selectable. Field names were paired correctly in Field Mapping. In this case I was transferring attributes from a point feature class to a polygon feature class. The solution which seems to work is adjusting the feature classes in the Drawing Order. When I had the point feature class lower than the polygon feature class in the Drawing Order it did not transfer attributes. As soon as I moved the point feature class to the top above the polygon feature class in the Drawing Order the attribute transfer tool started working. I am a little less certain how this trick would work with other geometry types, but I suspect the Source feature should always be on top in the Drawing Order and the Target feature below it. 

Tags (1)
New Contributor

I experienced the same issue but found that it works when the target layer is highlighted in the Contents window and the attribute table for the target layer is opened.

0 Kudos
Occasional Contributor

I'm still experiencing issues with this tool. I have to have my source layer turned on, click it, then turn it off and click the destination layer in order for the tool to work. I could save a lot of time it I didn't have to toggle the source layer on and off during this process 

Occasional Contributor III

I can't get this tool to work at all using any of these methods. I'm trying to transfer geometry (I selected Shape in the attribute mapper) from one polygon dataset to another and it's just not happening. 

0 Kudos