There are no appropriate templates

08-15-2019 08:06 AM
New Contributor II

I am using Pro 2.3.2. I am trying to copy line geometry from one feature class into a new, empty feature class. I successfully select the geometry I wish to copy and when I attempt to copy it into the new feature class, I get the error message that "There are no appropriate templates".

In the Manage Templates pane, there is very definitely a template for the destination feature class. I've even tried deleting and re-creating the template but this does not work.

Always, always "There are no appropriate templates".

I have resorted to working back in 10.6 in order to not be so frustrated by something so simple that won't work. I've referenced thread after thread I've found online about this - I've followed YouTube videos on how to do this everything I can think of and still "There are no appropriate templates".

At this point I see no reason to continue using Pro nor even bothering to transition to fully working in the platform. 

21 Replies
Esri Regular Contributor

Hi Craig,

I tried to reproduce, but so far, I can't. This seems like it could be data-specific. Are you able to share some details about the data here? If not, can you please reach out to Esri Technical Support to show them? We'd like to get to the bottom of this error.

Questions I have:

  1. What is the data source of each layer? (examples: a local File Geodatabase, an ArcGIS Online hosted feature service, etc).
  2. What kinds of fields are present on the data? (examples: text, date, blob, raster, globalid, guid, etc) - please try to be as specific as possible about this as it could be relevant.
  3. If you open the Create Feature pane before copying and pasting, do you still see the error?
  4. What is the specific workflow? Example:
    1. From the Edit tab, active the Select tool
    2. Select the feature
    3. From the Edit tab, Clipboard group click Copy
    4. Click the Paste drop-down and choose Paste Special.
    5. The Paste Special dialog opens and choose the template > OK.
      • FYI - the keyboard shortcut for Paste Special is CTRL+ALT+V.

Thanks for any further info to help us track it down.


New Contributor II

Hi, Scott.

Thank you for your reply.

Source data is a connected Oracle SDE corporate database that cannot be edited.

Destination feature class is in a local project file geodatabase and editing is enabled.

I have created a feature template which I confirm in the Manage Templates pane. I even went through the steps of deleting the feature template in this pane and then re-creating the template.

The source feature class is the ONLY SELECTABLE layer.

Field data types include:






Object ID


Workflow is identical to what you posted EXCEPT


5. The Paste Special dialog opens and there is a brief "pause" and popup window entitled PASTE SPECIAL FEATURES opens which says "There are no appropriate templates."

This happens using shortcut keys Ctrl-C / Ctrl-Alt-V or by clicking on the Copy / Paste / Paste Special menu items.

I very much appreciate your kind assistance.

Esri Regular Contributor

Thanks for all of that info, Craig. My hunch is the blob field is causing the error. Let me try to reproduce this scenario.

Esri Regular Contributor

Craig, I sent you a direct message. Hopefully you get a notification or email about it. Thanks, Scott

0 Kudos
MVP Regular Contributor

Hi Scott, 

My situation is very similar, except the source layer is a hosted feature layer.

Destination is an Oracle Enterprise GDB.

Were you able to resolve this?

0 Kudos
MVP Regular Contributor

Never mind, I tried:

"If you open the Create Feature pane before copying and pasting, do you still see the error?"

And the paste special dialog box came up as expected.

Thank you Scott Harris

0 Kudos
Esri Regular Contributor

Hi Andres,

In 2.5, the upcoming release of ArcGIS Pro, you shouldn't be required to open the Create Features pane first when pasting from a non-editable source; however, should you see the issue after 2.5 is released, please don't hesitate to reach out.



New Contributor III

Hi Scott,

 This is an issue now with my AGOL hosted features.

 It used to work fine but since 2.7.0 version it does not work.




0 Kudos
New Contributor II

Scott, we are using 2.9 and one of my employees is still running into this issue. It's strange bc I am working on the same database and not getting any such error so it's hard for me to troubleshoot it for her. I had her create a temp polyline feature class and when she did that it seemed to shock the system(for a lack of better words) into recognizing that there were actually "appropriate templates" for her to paste into but that was only a temporary workaround. Has there been any more feedback on this issue? I can't find much out there about this.