Spatial Join not working in Model Builder

388
2
01-21-2021 12:49 PM
Labels (2)
DanaThompson1
New Contributor III

Here is a Project Area that I am working with:

Spatial Join Project Area.JPG
Here is what my model currently looks like:

Spatial Join Model.JPG

My model gathers data from the line and the points and appends them into a new polygon feature class. I have two spatial joins to populate two fields in this polygon feature class. One is STRRange, which is to capture all the points that intersect with the polygon, and the other is StrApprox, which is to capture the nearest point if there are no intersections with the polygon. I've been running this model in 2.4.2, works perfectly. However, in 2.6 and 2.7 the StrApprox does not populate like it should, if it does not have a STRRange value, it returns blank. The left table is an example of how it's supposed to look like.

 Spatial Join Attribute Table.JPG      Spatial Join Attribute Table 2.JPG

Why is this happening?

 Spatial Join Window.JPG

0 Kudos
2 Replies
Robert_LeClair
Esri Frequent Contributor

Hmmm...in the Spatial Join GP tool dialogue box it says you have pending edits.  I wonder if this is blocking the Spatial Join from working?  Can you save your pending edits and run the model again? What is the result?

0 Kudos
DanaThompson1
New Contributor III

Thanks. I tried it but I got the same result. :\

0 Kudos