Notebook in ArcGIS Pro is not working properly

09-21-2021 12:41 PM
New Contributor


I run Notebook in ArcGIS Pro, but it is not working properly. For example, if I tried to type something in a Notebook, the interface would appear to be frozen. But when I clicked into another tab like a layout page and switched back to it, I can see that what I just typed. This is the same for all other operations. Other functions in ArcGIS Pro work normally. 

I don't know why this is happening. I tried to re-install the software, restart my laptop and nothing worked. Could someone please help me with this?


Tags (2)
3 Replies
New Contributor

I'm facing the same issue

0 Kudos
New Contributor

Hi there,

My problem is solved now but I am still not sure why. I could share with you what I have done and hope it's gonna help:

I first went to ask a professional. He said that it was probably hardware issues. It could be due to the small memory size. My laptop has 8GB, which is the minimum requirement for ArcGIS Pro 2.8. So it might be that when running Notebook, the memory was at maximum capacity and could not process properly.

I wanted to upgrade it. However, the day before I went to a computer store, I upgraded my system to Windows 11. When I was at the store and trying to show the Customer Service the problem, it magically worked! I am not sure if upgrading to Win 11 and running Notebook are related, but this works for me. So far I haven't met any more difficulties. 

Hope this could help you with the issues. Good luck!




0 Kudos
New Contributor

I too am having this issue, but can't find a solution.

0 Kudos