Merge tool does not function as expected

11-02-2021 09:17 AM
Occasional Contributor III

Wondering why the merge tool does not seem to be functioning properly in ArcGIS Pro 2.8.3. I created a model a few months ago that merges 5 polygon feature classes and then runs a series of GP tools to add and calculate new fields. The inputs to my model have changed so I map 9 new fields. When I run my model it fails at the next GP tool, stating that one of my new fields does not exist. I decided to run the merge tool outside of my model after many failed attempts to rectify the issue. Now even when I run the merge tool outside of the model it does not honor my new fields. I would like to see the POINTS, SCORE and VALUE/TOTAL fields from each of the 5 input polygons but the output only contains these fields from my address/density polygon.



0 Kudos
1 Reply
Regular Contributor III

Hello Sarah,

Try re-adding the features that you are merging then refresh the field map.  Sounds like the field map is hanging up on the changes.

Amanda Bishop, GISP
0 Kudos