How to turn off random multiple element select

268
5
07-18-2018 01:35 PM
RyanColeman
New Contributor III

In the latest version of ArcGIS Pro when I click a single element on the layout (eg. a text label), it also selects ~15 other random elements in the table of contents at the same time. These elements are not close to each other, they are not joined in some way or the same kind of element or any other similarity i can detect. Can you tell me why this is happening and how I can turn it off forever?

5 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Just to be clear... the very first time you clicked on a legend element, 15 others got selected?

Or are things gradually getting added as you select them?

Reply
0 Kudos
RyanColeman
New Contributor III

Right now if I click this text element "future parkway", it will also select a bunch of other elements I didn't click on. It's the same ones every time. I've seen this happen on several projects now.

they are not related in any way that I can tell

Reply
0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

So … no... to my first question. Several projects now... Did you create them? or are they ones you have been given? It is almost like you have the Select All toggled on (ie the keep last tool active)

Reply
0 Kudos
TomBole
Esri Regular Contributor

Hi Ryan, 

Looks like you have run into a bug. Though I am unable to reproduce the issue you describe with my own data/map/layout, I can think of no reason for this behavior outside of a bug. If you can, please take this issue to technical support. 

In the meantime, you can select the element you want to work directly from the Contents pane (the TOC). If you want to select elements interactively you can use the lock functionality to keep from selecting elements you do not want to select.

Here is a paragraph describing lock from the help topic Layouts in ArcGIS Pro—Layouts | ArcGIS Desktop 

Once added to a layout, elements can be selected, moved, and resized on the layout to achieve the desired look and feel. This behavior can be turned off by locking an element, preventing selection, moving, or resizing interactively on the layout. Switch between locked and unlocked views by clicking the Lock button Yellow lock next to the element in the Contents pane.

Hope this helps.

Tom

Reply
0 Kudos
AllisonGunther
New Contributor

I realize this is an old thread but I was just going crazy with this issue and agree it seems buggy but have found a successful workaround (and this was literally the only thing I could find anywhere on this issue and am sure other people have had this problem). 

Open up the map that is in the layout, go to the Selection Options and ensure "Selection combination" is set to Create a new selection and not Add to the current selection. 

This solved the issue for me even in an empty layout with graphic elements but no map.  It is somehow "remembering" previous selections of multiple elements for every time you try to select anything that was within the group selection.