Error 001378: Tool Available Fonts 10.x is unsupported on Server

3067
19
12-02-2021 10:25 AM
BrendonRapinchuk
New Contributor

We recently migrated our enterprise server from 10.3.1 to 10.9.1 and are running into issues whenever we try to publish anything to the new server. It always happens after "StatusMessage: Compressing package into SD file"

 

Below is the message we receive no matter if it is a full project or a blank map with just a shape file added.

"ErrorMessage: ERROR 001378: Tool AvailableFonts 10.x is unsupported on server

ErrorMessage: Failed to execute (Available Fonts).

ErrorMessage: Failed.

ErrorMessage: Failed to execute (StageService).

ErrorMessage: Staging failed"

 

I cannot find any information on AvailableFonts 10.x and the only info on ERROR 001378 says to replace the tool, but no instructions on how to go about that. Has anyone run into this or have any ideas on things I could try to fix it? I have had a ticket open with support for several days, but so far haven't gotten any guidance about this particular issue.

 

Thanks.

19 Replies
VishApte
Esri Contributor

I am also facing the same issue. I had running 10.8.1 and ArcGIS Pro 2.6.x. Using Enterprise Builder, I upgraded to 10.9.1 and upgraded Pro to 2.9 and now I cannot publish any new service. However, existing services continue to work. The staging part fails with below messages in the staging log.

Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:25 Status: InProgress StatusMessage: Start Time: Tue Dec 7 09:31:25 2021
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:27 Status: InProgress StatusMessage: ERROR 001378: Tool AvailableFonts 10.x is unsupported on server
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:29 Status: InProgress StatusMessage: Failed to execute (Available Fonts).
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:29 Status: InProgress StatusMessage: Failed at Tue Dec 7 09:31:25 2021 (Elapsed Time: 0.01 seconds)
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:31 Status: InProgress StatusMessage: Failed.
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:32 Status: InProgress StatusMessage: Consolidate data
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:32 Status: InProgress StatusMessage: Staging map service
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:36 Status: InProgress StatusMessage: Compressing package into SD file
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:36 Status: Failed ErrorMessage: ERROR 001378: Tool AvailableFonts 10.x is unsupported on server
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:36 Status: Failed ErrorMessage: Failed to execute (Available Fonts).
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:36 Status: Failed ErrorMessage: Failed.
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:36 Status: Failed ErrorMessage: Failed to execute (StageService).
Test 61 WebMapImageLayer ArcGIS Enterprise https://xxxx.xxxxx.xxxx.xx/server unadmin 2021-12-07 09:31:38 Status: Failed ErrorMessage: Staging failed

And ArcGIS Server Log as below: 

VishApte_0-1638830958844.png

Any help is much appreciated.

0 Kudos
lvargas
Occasional Contributor

Hello,

I have the same issue, the environment was upgraded from 10.9 to 10.9.1, we cant publish services from the Enterprise Geodatabase or create hosted services in the Data Store.

Services from Enterprise Geodatabase
Error executing tool. AvailableFonts Job ID: j86cfd3a995854107a0959d72ffb18424 : ERROR 001378: Tool AvailableFonts 10.x is unsupported on server Failed to execute (Available Fonts).
Error executing tool. Get Cache Info Job ID: jb5361ba350ef4b92b1c47959274ba0af : ERROR 001378: Tool GetCacheInfo 10.x is unsupported on server Failed to execute (Get Cache Info).
Error executing tool. Get Cache Info Job ID: j026561101e6f41adb77aa4fb40483aaa : ERROR 001378: Tool GetCacheInfo 10.x is unsupported on server Failed to execute (Get Cache Info).

Hosted Services
Error executing tool. Manage Feature Service Job ID: j7b1f33f0c6e14f2a962949dd0af0243a : ERROR: Operation is not supported. Failed to execute (Manage Feature Service).
xxxx/FeatureServer: ERROR: Operation is not supported.

Evidently it is something related to the 10.9.1 update.

Regards.

0 Kudos
RaúlAntonioPaduaAmparo
New Contributor

Has anyone found a solution?

0 Kudos
lvargas
Occasional Contributor

Not yet.

0 Kudos
Javier_Pintos
New Contributor III

I have the same issue. After upgrade ArcGIS Enterprise 10.8.1 to 10.9.1.

Has anyone found a solution?

Thanks!!!

0 Kudos
RebeccaWatson1
New Contributor III

Hi - did you resolve your issue? We are having the same problem following upgrade. Previous services are all running ok but no new service can be published due to:

ERROR 001378: Tool AvailableFonts 10.x is unsupported on the server

No solution from ESRI helpdesk yet.

0 Kudos
lvargas
Occasional Contributor

Hello,

I have created a support case with ESRI describing the incident, and a remote session was held; but a solution has not yet been reached.

In yours environments, do you have the Data Interoperability for ArcGIS Server or ArcFM Server installed?

Regards,

0 Kudos
Javier_Pintos
New Contributor III

We also opened a support case, did some tests but we are stuck.

We don't have datainteroperability installed. 

0 Kudos
RebeccaWatson1
New Contributor III

Hi - we do not have Data Interoperability for ArcGIS Server or ArcFM Server installed.

We are thinking it may be due to the arcgisserver system services (D:\arcgisserver\directories\arcgisoutput\System) not being updated when we did our upgrade from 10.7.1 to 10.9.1. We have two server set ups and one upgrade worked - one didn't. We can see that these files were all updated on the working one. We have manually tried to update some of these with json files as suggested by ESRI but this has not solved the problem.

The only difference between the two set ups is that on the non-working one the arcgisserver (C:\arcgisserver) and the arcserver application (D:\arcgisserver\directories\arcgisoutput\System) are on different drives whereas on the working one they are both on D:. 

We are also in discussion with ESRI and will update on any findings.

0 Kudos