Changing a domain code or description not saving in ArcGIS Pro 2.8

1664
15
08-13-2021 11:36 AM
Labels (2)
StefanieWenker
Occasional Contributor

I am trying to update the coded value and the description of existing domains in our SDE (10.4.1)

When I add or delete values in the domain I see the indication that I have changed something in the domain by the green or red column in front of the values, and the Save button ungreys.

However when it is only the text inside the codes and description that I am changing, there is a little red exclamation mark that shows up as I am typing, and when I click out of the input boxes I have changed the text for, the exclamation mark disappears and there is no indication that I made any changes. The save button in the domain ribbon stays grey and when I close the domain view, I am not prompted to save my changes. When I close the project and reopen it, the changes aren't there. 
I have tried hovering over the exclamation mark, but there doesn't seem to be anything there.

I also checked to make sure I didn't have any unsaved feature edits. I turned on the option to be able to start an edit session for the project and made sure no edit sessions were on.

Just upgraded to Pro 2.8.2 from Pro 2.8.1 where I was first having this issue, but it doesn't seem to have helped.

15 Replies
JessicaJThompson
Occasional Contributor

Yes, I am having a similar issue and looking for a solution. The edits I am making to fields or domains, either in the pane view or via a geoprocessing tool do not save consistently. Even when it says the process was was successful, the change was not applied. Sometimes after closing the project (sometimes restarting my PC) and reopening, the change will be applied. Other times it does not. I am so confused what may be causing this inconsistency. 

I just updated to Pro 2.8.2 today. Restarted my PC and the issues are still occurring. 

pkorst_coa
New Contributor III

I am experiencing a similar problem saving Domain Code Description changes with ArcGIS Pro 2.8.2 using a newly created local File Geodatabase.

After editing a Domain Code, or the Description, I find that the Save button (in the Changes group) is not activated (remains greyed out) and my edits cannot be saved. 

My project does not contain any unsaved feature edits. In fact, I have closed the project and reopened it, and then immediately attempted to make edits to the Domain Code and/or Description, but am unable to Save my edits as the Save button remains greyed out.

AdrianWelsh
MVP Notable Contributor

I had the same thing happen to me. The only way I found around it was to just create a new domain from scratch. This is not a sustainable workaround.

 

ArcGIS Pro 2.8.2 - locally stored file geodatabase.

TeresaWhitney
New Contributor II

Has anyone submitted this issue to Esri? I am also having this problem.

VinkelRasmussen
New Contributor

I was having the same problem, but I think I found a workaround. I edited the description of my domain, and then changed the description of the code values in the domain. I couldn't change just the code descriptions, I had to edit something else. When I did that I could save my changes.

0 Kudos
JillHalchin
Occasional Contributor II

2.8.1 and a file geodatabase.  I had no problems earlier this week when I started working on several domains, but today I'm not able make changes.  Closed and reopened Pro, compacted the geodatabase.  Will request a ticket with Esri.

 

0 Kudos
IsaacUbben
New Contributor

I came across this thread as I was having the same issue. I was able to get the domain changes to save, but I had to remove the domain from the feature class being used. With it removed, I was able to save the changed domain and then just tag it back onto the feature class. Not really feasible if you have one domain being used across many feature classes, but it was okay for me in this case. 

0 Kudos
JillHalchin
Occasional Contributor II

Reporting back after talking with Esri.  Their rep, Maria, tested it and found that depending on the way you opened the Domains window made a difference in how it acted (or acted up).  Also, she checked 2.9.1 and it worked correctly.  It took a few weeks for me to get 2.9.1 installed, but so far, domains are working fine for me now.

AndrewDeLuca
New Contributor III

Did your rep tell you which way would allow the domain window to function correctly? I am now having this issue.

0 Kudos