cannot load a notebook from a unc path

5338
21
Jump to solution
07-01-2020 06:10 AM
BertKraan1
Occasional Contributor III

So, I create a notebook in arcgis pro 2.5.2, open the catalog pane, click the notebook and ...

why is it a problem to open a notebook from a unc path?

I can't imagine I'm the first to run into this, could not find it here though, anyone who knows a way out of this?

regards,

Bert 

Tags (1)
1 Solution

Accepted Solutions
DannyMcVey
Esri Contributor

Thanks everyone in this thread for your feedback and use cases.

Support for notebooks on UNC paths in Pro is planned for ArcGIS Pro 3.0.

View solution in original post

21 Replies
Robert_LeClair
Esri Frequent Contributor

Bert - I researched your question about UNC paths and Notebooks and there was a Support Service request for this exact item.  It is reproducible in AGP 2.5.0 and 2.5.1.  As the case was in mid-June, AGP 2.5.2 was not yet released publicly.  The current workaround is as follows:

"we are currently unable to connect directly to the UNC path within ArcGIS Pro, as a workaround though aside from mapping the drive we can create a symbolic link to the UNC path reference: https://support.esri.com/en/Technical-Article/000022743 which will create a shortcut to the UNC folder, this is the recommended workflow to follow,"

Hope this helps!

JaredPilbeam2
MVP Regular Contributor

@Robert_LeClair 
I'm using Pro 2.6.0 and this problem still exists. In the catalog, when I attempt to add a New Notebook I get the same error. It does get created, but it won't load.

JaredPilbeam2_1-1606167862055.png

Just giving you a heads-up. I ended up creating a Notebook from Folders in the catalog. I have a connection to a folder in my C drive.

Robert_LeClair
Esri Frequent Contributor

Hi Jared - thx for the response.  Question for you - by chance are you on a Citrix environment?

JaredPilbeam2
MVP Regular Contributor

No, I don't think so. I'm not even sure what that is, and it's not installed on my machine(s).

Robert_LeClair
Esri Frequent Contributor

Okay - thx for the info.  Question - when you installed AGP 2.6.0 was it a clean install meaning you completely uninstalled AGP 2.5.x?  Then installed AGP 2.6.0 on your PC.  Or upgraded from AGP 2.5.x to AGP 2.6.0?  I've seen strange occurrences like this when it's a upgrade workflow vs. a uninstall/install workflow.

JaredPilbeam2
MVP Regular Contributor

Well, my memory is getting a little muddled now. But, a short time ago I was getting this same UNC path error, so an ESRI tech I made a case with suggested I completely wipe AGP from my machine (which was then running 2.6.0). So, I did that and then reinstalled AGP 2.6 anew from a .exe file we keep stored on in network folder. After that reinstall, I'm pretty sure I was able to create a new Notebook. But, now it somehow relapsed back to not letting me create a new Notebook.

Daniel_Hardwick
New Contributor III

Hi Robert, 

 

I have just ran into this problem myself. I am new to Notebooks but wanted to try it in Pro, then I ran into the error and found this thread. I noticed you said you got it to work by creating the Notebook within the Folder within the catalog pane. When I try to do this I get the same error? Did you literally just right click within a folder and create notebook?

I have also tried the Windows folder shortcut solution, but this also didn't seem to work, but this could have been due to not being entirely sure what I am doing! When creating a folder shortcut you have to specify two folders, one for the shortcut folder, and the other for where the data is. I don't really have any data in mind particularly, I just wanted to connect to a Notebook and import some libraries and so on. So I created the shortcut within my personal folder, for example "\GISDrive\Data\ESRI GIS\ArcGIS Pro Users\MyUserName\Template Map\Shortcut_Folder", then for the data folder I pointed it to the same 'Template Map' folder, seeing as I don't have specific dataset I want to use at this point. It created the shortcut fine but if I try then to create a Notebook it fails. 

Is there a particular folder where the Notebook needs to be pointing to, for example C:\? 

Thanks

0 Kudos
JaredPilbeam2
MVP Regular Contributor

That's what I did. I right clicked within the catalog window.
notebook.png

0 Kudos
PaulCone2
Occasional Contributor

This is still a problem in 2.7.3.  Is it going to get fixed?  Or does ESRI still expect me to open up a command line to work around it?