Composite locator doesn't find candidates. But (the real kicker here) Locate tool finds address using locator inside defective composite locator.

907
3
Jump to solution
05-13-2022 01:16 PM
Labels (1)
CarolinaBaumanis
New Contributor II
I’m trying to geocode intersections (using “&” as the connector) with a composite locator I made myself. The composite locator is not behaving how I would expect, and I cannot really find anything online that talks about the problem I’m experiencing…

For my unmatched addresses, I’m seeing zero candidates in the Rematch Addresses window. But the Locate tool finds the intersections without any issue using my self-made locator (called AllStreets_UTM). I’ve tried to clean up or modify the address inside the Rematch Addresses window to match the perfectly match the results from the Locate (via my locator), but still – no candidates. I’ve attached a screenshot to show what I’m visually seeing. I’m at a loss at what the issue is!

I’ve rebuilt the locator so many times and I don’t understand why it cannot find these addresses. I also updated the software, updated my computer, restarted it, everything… Would appreciate any insight!!

0 Kudos
1 Solution

Accepted Solutions
CarolinaBaumanis
New Contributor II

I got it to work by deleting the zip code field in the unmatched addresses. As soon as I deleted that field, it was able to find a match with the locator I created! 

View solution in original post

0 Kudos
3 Replies
CarolinaBaumanis
New Contributor II

I should clarify: it's matched about 50% of the addresses I've asked it to geocode. The issue is the unmatched addresses when I'm going through the rematch address procedure

0 Kudos
ShanaBritt
Esri Regular Contributor

It looks like the 'AllStreets_UTM' locator was created with out city, state, zip mapped based on the images provided. In the Rematch Addresses backstage where you see the Input Address Fields and the settings, what happens when you change the Input Address Fields to Single  Field instead of Multiple Fields and select the field that contains just address or intersection?

What is the result when you geocode the table and select Single Field initially in the Geocode Addresses tool or Geocode Table pane?

It would be helpfult if you provided a screenshot of the Reference data section of the Locator properties for the AllStreets_UTM locator.

CarolinaBaumanis
New Contributor II

I got it to work by deleting the zip code field in the unmatched addresses. As soon as I deleted that field, it was able to find a match with the locator I created! 

0 Kudos