ArcGIS Pro Layer to KML: FolderPath not being used

1591
7
10-18-2016 12:37 AM
JaySu
by
New Contributor

I have feature layers i am attempting to export to KML from ArcGIS Pro 1.3.  The KML is successfully generated, but all features are in a single folder.  I'd like the exported KML to have a folder structure like 'Attribute1' / 'Attribute2'.  I have created a FolderPath field and used Calculate Field to set its value to 'Attribute1' / 'Attribute2'.  Unfortunately, the FolderPath values appear to not be honored when the KML is generated.  What am I doing wrong?

7 Replies
DanPatterson_Retired
MVP Esteemed Contributor

you are referring to KML Conversion—Conversion toolbox | ArcGIS for Desktop in the folders and subfolders section.  The example isn't clear, but your example has the paths enclosed in quotes and separated by the / as indicated... what if the quotes are removed?

0 Kudos
JaySu
by
New Contributor

Sorry my first post is misleading:

i'm actually setting FolderPath using Calculate Field: FolderPath = !ATTRIBUTE1! + '/' + !ATTRIBUTE2!, and it's not working.

Also possibly related: I configured pop-ups for the layer and those are not being used when exporting to KML either (despite documentation which says it would).

0 Kudos
JoeChampagne
Occasional Contributor

Hi Jay,

I don't know if you ever got a resolution on this issue, but I found this post shortly before I discovered for myself that this functionality still isn't working as of ArcGIS Pro 2.0.

HOWEVER, much to my surprise the 'Layer to KML' tool does accept a FolderPath field when running it out of ArcMap (I'm at 10.3). Good to know that this (sorely under-documented) functionality is available somewhere in the Desktop platform.

Good luck!

MichaelFennell
New Contributor

Hey Everyone,

I know this is an older thread, but even in the latest version of ArcPro (2.3) we experience the same issue described above in the original question. We can get the FolderPath to work in ArcMap, but not ArcPro. 

Thanks for any advice you have!

ThomasL
Occasional Contributor

I see this was reported in 2016, but in ArcGIS Pro 2.5.2 the same behavior is still occurring for me.

Any updates to when this will receive some loveKory Kramer  ?

Or is ArcMap > ArcGIS Pro still true in 2020   

Bug Number: BUG-000121722: The Layer To KML tool folder path is not honored.. 

0 Kudos
KoryKramer
Community Moderator

I checked in with the team on this bug and it looks like they'll be doing some wide-ranging work on layer to KML tools for ArcGIS Pro 2.7.  This should get attention during this release cycle.

Thank you.

ThomasL
Occasional Contributor

@KoryKramer , BUG-000121722 is listed as fixed in ArcGIS Pro 2.7 , but in my testing the "FolderPath" feature is not working in version 2.7. 

When I export a point fc with 6 features using "Layer to kml", this is all the data that is exported in the kmz file, besides the header:

 

 

<Document id="Cat1">
  <name>Cat1</name>
  <snippet></snippet>
  <description><![CDATA[map]]></description>
</Document>
</kml>

 

 

 

I also found a "debug.log" in the project folder stating:

 

 

[1219/134021.263:ERROR:directory_reader_win.cc(43)] FindFirstFile: The system cannot find the path specified. (0x3)

 

 

 

I added the ArcGIS Pro test project to this post and reported the bug to support.

I hope this bug finds some love 🙂

Tags (2)
0 Kudos