ArcGIS Pro 2.4 cannot open 2.4.1 aprx files

1109
5
08-27-2019 03:08 PM
AndrewNeuman
New Contributor

I've discovered that I cannot open projects created with ArcGIS Pro 2.4.1 with ArcGIS Pro 2.4. I've created projects and sent them to others and had them not open them and I've also had projects sent me that were created in 2.41. and not open in 2.4 (I rolled back). 

There is also no options to save as <previous version>. 

Is anyone else having this issue?

0 Kudos
5 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Kory Kramer‌ flag in case this hasn't been noted by others.

0 Kudos
ThomasColson
MVP Frequent Contributor

"There is also no options to save as <previous version>. ".

Let's hope we see this important missing functionality returned in 2.5. 

0 Kudos
MarkJackson
Occasional Contributor

This would be a huge problem for me as there is always one department that lags on pushing out the updates so I just did some testing. I hate posts that say "It works for me" implying you're doing something wrong. I really don't want to face this so I'd like to figure it out.

Here's my setup:

ArcGIS Pro Advanced 2.4.1. --> ArcGIS Pro Advanced 2.4

Named User License (ArcGIS Online) -> Works

Concurrent Use License -> Works

1. Opened 2.4.1 made a new map, added a map and a couple of data layers (from geodatabase on local machine) and saved.

  • Opened in 2.4 on a different machine without issue

2. Saved a complex project with multiple maps, data sources (tables, Revit, SDE, WMTS, WFS, mapped drive, UNC path) in 2.4.1.

  • Still opened in 2.4 without issue.

Are you getting an error message that says it isn't opening because it was created in a newer version? Even going back to 2.3 it just tells me that any features that are from 2.4 won't work, but still opens the project. 

KoryKramer
Community Moderator

Andrew Neuman‌ I tried to reproduce this and I am able to open a Pro 2.4.1 project in Pro 2.4:

It would be important to understand any specific details about what is in your 2.4.1 projects that would cause this.   It would be interesting to check whether packaging the project and sharing the project package with colleagues on 2.4 has any different outcome.  i.e. even if you use the CURRENT version setting in Package Project—Data Management toolbox | ArcGIS Desktop  can they open it in 2.4?

Otherwise, from 2.4.1 you could package to 2.3 to share, but again, that doesn't really get at why your 2.4.1 projects aren't opening in 2.4.  If you're able to share any more details, or a 2.4.1 project package that you've tested and confirmed won't open in 2.4, we could have somebody take a look...

0 Kudos
ChelseaRozek
MVP Regular Contributor

FYI to people stumbling across this thread: I tried opening a 2.8.1 aprx in 2.7.3 and it warned me that the aprx was created in a later version of ArcGIS Pro and that anything that wasn't compatible (new functionality etc.) would be lost if I saved it in 2.7.3. When you accept, it opens it in the lower version. In my case, I was able to save it fine because it was a pretty simple aprx.

0 Kudos