Select to view content in your preferred language

Am I the only one with broken/mismatched Select and Explore tools

976
5
02-07-2019 09:46 AM
CheyneHadley
New Contributor III

Whenever I'm using either the Select or Explore tools to navigate and select feature, ArcGIS Pro 2.3 will switch and/or break the functionality.  This was rare in 2.2, but now it breaks within 5 minutes of opening the software--every time.

Specifically:

1. click Select tool

2. select a feature

3. click somewhere in any open attribute table.  The selected tool change to the Measure tool

4. click the map

5. now the select tool pans the map

The mouse cursor is still the Select tool, until I click on the map, where it will change to the closed hand cursor until I release the mouse button.  It only pans the map, as I still have to select Explore if I want to identify features.  Even though the Measure tool appears to be selected at this point, you cannot measure anything.

To Return to Normal:

0. the Clear button clears the selection, but does not fix the situation

1. click the Select tool again to select features or the Explore to identify features

To Measure features:

1. click either the Select or Explore tool to reset the bug

2. click the Measure tool

Sometimes, when I'm using the Explore tool, it suddenly starts selecting features instead of panning the map.  This is less common, and I don't have a specific use case to recreate it, but it's still related and worth mentioning.

Kory Kramer

0 Kudos
5 Replies
KoryKramer
Esri Community Moderator

What antivirus software are you running?

0 Kudos
CheyneHadley
New Contributor III

ESET Endpoint Antivirus

Version 6.5.2107.1

0 Kudos
KoryKramer
Esri Community Moderator

Sorry that you're running into this, Cheyne, and thank you for pointing it out.  We're able to reproduce the behavior so I've logged the following bug:

[BUG-000119926: When Measure tool is added to another ribbon through the Customize the Ribbon options , with Select tool active, clicking in an attribute table highlights Measure tool in ribbon, and switches Select tool to Explore tool functionality.]

If you would like to be attached to this bug for tracking purposes, please DM me or email kkramer@esri.com with your customer number.

Thank you.

CheyneHadley
New Contributor III

Thank you for looking into this.

Matt-Goodman
Occasional Contributor

I have noticed similar issues with ArcGIS Pro, in which the chosen tool seems to be different from the tool that the interface initializes. 

0 Kudos