Explore tool does not identify after geocoding

369
5
03-05-2019 05:06 AM
Timvan_Asperen
New Contributor

Hi,

Recently I've had some problems with left clicking on the map after geocoding a table, using the ArcGIS World Geocoding Service. When I left click on a map or on a feature, no blue circles appear and no popup appears, basically nothing happens. After uninstalling the latest version of ArcGIS Pro (2.3) and installing 2.2.1 again yesterday I got rid of the problem. But after geocoding again today, I got the same problem. Updating to version 2.3 didn't fix the problem. Another thing that I noticed that if I now randomly right click on a map and click 'what is here' it pulls a random line to the top right of the screen, which goes on endlessly (which isn't the biggest problem but maybe related?).

 

Thanks for your help!

5 Replies
EricAnderson17
Occasional Contributor

Hi Tim van Asperen

So just to clarify your workflow, you batch geocode a table of addresses using the World Geocoding Service, and then attempt to left-click on one of the geocoded features but no pop-up appears. Is that correct?

It would be expected that simply left-clicking on an empty space in the basemap (without any features underneath) would not do anything, but clicking on one of your features should definitely bring up the pop-up. 

Have you tested with multiple sample tables? If its specific to one table, are you able to provide this to us? 

If you remove the geocoded results from the map and re-add them, are you able to open the pop-ups?

Do you see this issue with layers that have not been geocoded? 

The issue with the "What's Here?" right-click function is certainly odd as well. Introduced in 2.3, this now shows a dotted line connecting where you right-clicked on the map, and where the address is actually located in the real world. Clearly its not expected the real life feature is off the map like in your screenshot. Can you reproduce this when using the "What's Here?" function in other parts of the world as well?

-Eric

Reply
0 Kudos
Timvan_Asperen
New Contributor

Hi Eric,

That is exactly my workflow.

I've tried this with two different tables. The first time with a larger

table (+-25000 addresses), I reinstalled the program afterwards (as I

mentioned in my first message). The second time with a much smaller table

(+- 700 addresses). Both tables were geocoded on ZIP codes, in The

Netherlands on the lowest level (PC-6, for example 1234 AB). These tables

were made in Excel sheets, but unfortunately I cannot share this data.

I've tried sending the layer to a colleague, who didn't have any problems

with left clicking or getting popups.

Also removing the layer from the map didn't solve the problem, I could

still not left click, on any layer or basemap whatsoever.

Concerning the "What's Here?" function. While using this function, all

addresses over the world showed a line going to the right side of the

screen. But they didn't all go to the same point, some lines were almost

going straight up while others were more going to the right.

I've reinstalled ArcGIS Pro again and I haven't got any problems with the

features now. But I haven't tried geocoding again yet, I'll probably find a

other way to reference the locations to the map.

Tim

Op vr 8 mrt. 2019 om 17:25 schreef Eric Anderson <geonet@esri.com>:

GeoNet <https://community.esri.com/?et=watches.email.thread>

Re: Explore tool does not identify after geocoding

reply from Eric Anderson

<https://community.esri.com/people/EAnderson-esristaff?et=watches.email.thread>

in ArcGIS Pro - View the full discussion

<https://community.esri.com/message/836859-re-explore-tool-does-not-identify-after-geocoding?commentID=836859&et=watches.email.thread#comment-836859>

Reply
0 Kudos
EricAnderson17
Occasional Contributor

Hi Tim,

That certainly is some odd behavior, but I'm glad to hear that re-installing the software has resolved these issues for now. The fact that your colleague was able to geocode the table and bring up the pop-ups tells me it wasn't an issue with the input tables anyways and most likely something with your install of ArcGIS Pro or your machine. If the issue returns, it may be good to test on another user profile on the same machine as well. 

If you notice the issue return and you'd like us to investigate this a little more thoroughly, I definitely recommend you open up a case with Esri Support. 

Best regards,

Eric

Reply
0 Kudos
RobbynAbbitt
New Contributor III

Hello - I am using ArcPro 2.6.1 and I am also having this same issue.

I just batch geocoded a small list of addresses using an Address Locator I created from a local roads dataset.

Everything seem to be fine except for the Explore tool does not work to do the Identify function...

Reply
0 Kudos
ShanaBritt
Esri Regular Contributor

Robbyn:

When you click the Explore drop-down, are there any options checked? If not, check one of the first three options in the list, then try to identify a feature.

Reply
0 Kudos