error message when attempting to take maps offline with collector since ArcGIS online update

1123
8
Jump to solution
03-20-2019 04:00 PM
EmilyTys1
New Contributor II

I have been unable to take maps offline in collector since the update on March 19 (PDT). Both my maps have been taken offline successfully previous to the update. I had made no changes to these maps. I have services hosted online, published in ArcGIS 10.4. I am using Collector Classic. I have also tried in the new Collector app but that also failed. The error message I am getting is:

   "Unable to create replica. Please check your paramaters. Create replica internal error. "

I have tried republishing the services and creating a new map with the new services but still got the same error when I attempt to take maps offline.

1 Solution

Accepted Solutions
EmilyTys1
New Contributor II

Hi Robert - the issue I was having turned out to be the result of a bug (BUG-000121058 Downloading a web map for offline use in Collector for ArcGIS (Classic) returns the following error message: "Unable to create replica. Please check your parameters. Create replica internal error.") which has now been resolved and we are no longer having this issue. I'm afraid that's not much use to you if you are still getting a similar error message. Hopefully esri can resolve for you. Goodluck!

View solution in original post

8 Replies
AnuSawant
Occasional Contributor II

I am having the same issue but only to those web map where I have used an ESRI feature service template. After checking a solution on Geonet I have found this Collector App - Unable to create replica. Please check your parameters . which is not relevant in my case.

So I have to download these feature services as an individual feature class and then disable Z and M values and then publish back as a new hosted feature service and then again create a new web map from scratch. Which work absolutely ok.

In my case that web map was completely working before the server maintenance on March 19.

Regards,

Anu

0 Kudos
EmilyTys1
New Contributor II

Thanks for your help Anu, but I am not using esri feature services templates and do not have have m or z enabled feature classes included in my feature services. None of the issues in the geonet solution were relevant to my circumstances either. I have logged a support request with esri so hopefully they can help.

Regards,

Emily 

0 Kudos
RobertRayner1
New Contributor III

I am getting this same error Emily, and I've narrowed it down to a few specific layers. These layers do not have Z or M values, Versioning and Archiving are disabled, and they were published from Survey123 Connect when creating a survey. I've tried re-publishing, putting them in new maps and every time the offline download fails. None of the other help threads on geonet have helped either, I've tried enabling/disabling offline on the map, adding a feature and attachment and re-saving, enabling/disabling sync on the specific layer...

I have a support ticket open with Esri as well. Did you figure this issue out?

Russell Roberts‌ 

Miaogeng Zhang

Kylie Donia

#collector aurora

#failed replication

0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Hi Robert - Do you have a map and services you can share with user Collector4ArcGIS? (To share them, create a group and invite that user to it, and share the map and services with that group).

RobertRayner1
New Contributor III

Hi Kylie, I have added Collector4ArcGIS to a group with a map and one of the layers which causes the error 500: Unable to create replica. Please check your paramaters. Create replica internal error.

Theodore Simons‌ is also working on this from the ESRI support side. 

0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Thanks Robert Rayner‌! I will let support move ahead with this as they have a better system for getting repro cases, and they'll loop in others as they need. Please reach out again if you feel I could help more.

0 Kudos
EmilyTys1
New Contributor II

Hi Robert - the issue I was having turned out to be the result of a bug (BUG-000121058 Downloading a web map for offline use in Collector for ArcGIS (Classic) returns the following error message: "Unable to create replica. Please check your parameters. Create replica internal error.") which has now been resolved and we are no longer having this issue. I'm afraid that's not much use to you if you are still getting a similar error message. Hopefully esri can resolve for you. Goodluck!

BobWheeler
Occasional Contributor

I'll throw my hat into the arena as well.  Previous maps that could download no longer can.  My first issue was I had a duplicated feature class symbolized differently.  Not supported in this version of Collector and on-prem Portal.  Worked fine in AGOL last year, but I guess that was last year and I was trying to stay local.  I've since removed the duplicated FC, but still no success.  I continue to test specific layers without success and errors are cryptic error 500 - unknown.

0 Kudos