AGO Update Data button: Overwrite Entire Layer replaced with Append Data to Layer option

05-25-2021 01:26 PM
New Contributor II

I have three hosted feature services in ArcGIS Online that I originally created a couple of years ago from Google Sheets using the instructions found here: Periodically, I update them from the Google Sheets using the Update Data button on the Item Details page, selecting the Overwrite Entire Layer option (the only option I see). This is quick and easy and works great.

However, once in a while, one of them will suddenly lose the option to Overwrite Entire Layer and instead only allows me to Append Data to Layer. I can never figure out why this happens, as the Google Sheet's structure and permissions have not changed. Once this happens, the ability to overwrite the layer from the Google Sheet never seems to return.

If I create a new version of the feature service using the same Google sheet, I am once again able to update by overwriting the layer. My other option is to download a CSV file from the Google sheet and use the Append Data to Layer option, but that involves extra steps that I'd prefer to avoid.

Does anyone know what causes this to happen and if there's a way to repair the feature service's link to the Google Sheet (if losing it is what has caused the issue)?

Thanks in advance!


2 Replies
Occasional Contributor

I have the same issue although, it seems that I can access the overwrite from some layers of my content but not in others. I'm still trying to determine why or what the difference is. This is frustrating in that I have to remove the service or hosted feature layer and publish a new one. Hopefully someone will provide some thoughts on this. Thanks for posting! Kristal Btw I did find this article which explains a little more about the append process but I'm still confused about why it shows up in some places and not in others. What's new with hosted feature layers - getting to know append Part I DEC 2017 

Kristal Walsh
New Contributor II

Thanks for the response! Good to know it’s not just me!


0 Kudos