FeatureLayer - a single point label disappears beyond a certain scale

09-28-2022 08:05 AM
New Contributor III

I have a FeatureLayer of points which is dynamically created from json (pulled from a database). When labels are switched on there is just a single point which misbehaves when zooming past a certain level. The label will display at smaller scales if I switch off smart labelling (deconflictionStrategy: 'none'), but then disappears and doesn't reappear after zooming past a certain level. All the other points behave normally. It is nothing to do with scales, whether I set a maxScale or minScale or no scales at all and I have also tried different label placements. If I change the Y coordinate of the point by the 5th or 6th decimal point (i.e. sub-meter - gps points in DD) then the point label will behave and show at all levels.

I have also tried isolating the point so there are no others in the layer but the label still disappears. This is an edge-case issue as hundreds of these layers are viewed everyday but it has only been spotted by users a handful of times.

I am using 4.23 but have also tried 4.24 but to no avail.

Any suggestions appreciated

0 Kudos
0 Replies