Default extent on items

456
23
02-13-2020 05:15 AM
Highlighted
New Contributor III

Previously the default extent on the map when you viewed a dataset on our open data site seemed to work without issue, the extent was appropriate for each dataset.  Now we have a zoomed out globe on everything..  we have switched data sources recently but this was an issue before that change.  

I've been trying to find out where its set but can't find the answer, was hoping it was in the item in AGOL but they all zoom to the right place without any issue so its obviously not that.  

Example here.

Thanks

Anne

23 Replies
Highlighted
Occasional Contributor II

Hi Anne Tetley‌ thanks for bringing this to our attention, we'll investigate what might be going on and get back to you quickly.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Still working on isolating the issue, will report back.

Reply
0 Kudos
Highlighted
New Contributor III

Thanks Brian, if you need any more info let me know.

Anne

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Anne Tetley‌ apologies for the delay here, this was big one to tackle...fix coming out on Tuesday 🙂

Highlighted
Occasional Contributor III

I've been fighting this for years! I want the extent of my item (aka map service) to be honored! Not some unknown extent that is irrelevant to my data!

Reply
0 Kudos
Highlighted
New Contributor III

That's fantastic Brian, thank you so much for following up on it.

Reply
0 Kudos
Highlighted
New Contributor III

Brian Rollison‌ - We're seeing this same issue in our Hub. The initial extent for our items isn't based on the features in the layer. We tried updating the extent in the feature layer settings but no dice. Feel free to have a look at our hub to see what I'm talking about: https://geohub.roundrocktexas.gov

Reply
0 Kudos
Highlighted
Esri Regular Contributor

we're looking into this! apologies for the issue

ps nice looking site!

Reply
0 Kudos
Highlighted
New Contributor III

Thanks Graham Hudgins‌. Will be on the lookout for an update!

Reply
0 Kudos