Default extent on items

1656
29
Jump to solution
02-13-2020 05:15 AM
AnneTetley
New Contributor III

Previously the default extent on the map when you viewed a dataset on our open data site seemed to work without issue, the extent was appropriate for each dataset.  Now we have a zoomed out globe on everything..  we have switched data sources recently but this was an issue before that change.  

I've been trying to find out where its set but can't find the answer, was hoping it was in the item in AGOL but they all zoom to the right place without any issue so its obviously not that.  

Example here.

Thanks

Anne

29 Replies
PatrickHammons1
Esri Contributor

I'm not able to consistently set/save the extent for sites so it looks like there are more extent bugs than I originally thought. We're working on some fixes and will test with your site, hopefully releasing next week. Thanks for your patience.

0 Kudos
Mandalorian
New Contributor III

Patrick Hammons‌ - No worries. Appreciate the help. Let me know if you need to loop me in for any setting changes/testing. Feel free to email me: nsmith@roundrocktexas.gov

PatrickHammons1
Esri Contributor

The last place to try is the item extent (which you appear to have already tried above) for the disc golf item in ArcGIS Online. We're still showing the zoomed in extent in the server response, so either it hasn't been updated or something isn't being passed to the Hub app.

0 Kudos
Mandalorian
New Contributor III

Patrick Hammons‌ - That's right. Also tried that. I went ahead and screencast what I did so you can confirm I did that right: 09.18.2020-15.55.05 

0 Kudos
VanDerWielenTonyJ-DOT
New Contributor

Is there an update on this issue? I can't set the extent anywhere and make it stick on individual content items in my open data hub!

0 Kudos
NCESOpen_Data
New Contributor II

Are there any updates on this issue? The recent HUB update has made this problem even more obvious for my datasets.

0 Kudos
AnneTetley
New Contributor III

Also still struggling with this, frustrating as its currently showing really unhelpful extents with our data not even visible anywhere on it.  I've tried updating the Hub site default extent and the item default extents and nothing seems to affect it.

0 Kudos
PatrickHammons1
Esri Contributor

@AnneTetley @VanDerWielenTonyJ-DOT @NCESOpen_Data sorry to hear you're all continuing to observe extent issues. We made an update a couple of months back to give preference to item extents when they exist. You can edit this on the item level in ArcGIS Online under settings:

Screen Shot 2021-08-12 at 5.00.09 PM.png

If you've already tried this (as it sounds like you have @AnneTetley) then I would have to investigate further. Would you be able to forward a link to an item with an incorrect extent?

View solution in original post

0 Kudos
AnneTetley
New Contributor III

I hadn't spotted that Extent setting on the item!  I'd been using the visualisation tab and "Save layer".  Thank you this has rectified the issue with this layer.  Many thanks for your help.

 

Anne

0 Kudos
NCESOpen_Data
New Contributor II

Hi Patrick,

I'm still having trouble with this issue. My Public School Characteristics file displays the data at a global scale when I view it through Open Data.

NCESOpen_Data_0-1629748929999.png

But the extent is set to the contiguous US as seen in the screenshot below in ArcGIS Online.

NCESOpen_Data_1-1629748966498.png

 

0 Kudos