Map not displaying on public website despite meeting Embed and Publish Check

1586
5
06-26-2023 11:49 AM
Labels (3)
noor
by
New Contributor

Hi everyone,

I am trying to publish and P.BI dashboard with an esri map inside. The map meets all 4 of the Embed and Publish checks, but when its published online, the map does not display. Instead, I get the following message on the map:

 

This map does not meet the requirements for published reports. 

This map was previously displayed with no errors on the same public website.

Any suggestions?

5 Replies
NaZhang_Esri
Esri Contributor

Hi @noor,

 

Thanks for the question! That's an interesting question! Please double check if you add data to both the Location and XY field wells. If this is the case, please remove data from the Location field well and see if it's working. 

 

Here are some resources on Embed and publish the report

Publish to Web:

https://doc.arcgis.com/en/microsoft-365/latest/power-bi/publish-to-web.htm

Embed map

https://doc.arcgis.com/en/microsoft-365/latest/power-bi/embed-a-map-enabled-report.htm

Sharing reports in Power BI using ArcGIS for Power BI Blog:

https://www.esri.com/arcgis-blog/products/power-bi/sharing-collaboration/sharing-reports-in-power-bi...

 

If these resources are not helpful, much appreciated if you could provide more details on your question. 

 

Regards,

Na Zhang 

Product Engineer – ArcGIS for Power BI

 

 

 

 

0 Kudos
DLynch_GCWATER
New Contributor II

I am having the same problem. Simple Lat and Long values added to the Latitude (Y) and Longitude (X) wells, nothing in the Location well. Validation checks all pass in PowerBI Desktop, publish the report from PowerBI desktop, open the report in the PowerBI service and save, generate embed code (tried all 3 embed types), and the map will not display. My table, slicers, visuals, etc. all display, but the map area shows the "This map does not meet the requirements for embedded reports". ESRI please advise.

NaZhang_Esri
Esri Contributor

Hi @DLynch_GCWATER ,

 

Could you please try to sign in with your valid ArcGIS credentials in your report and then embed and publish the report?

 

In order to embed and publish the report, ArcGIS sign in is required. 

 

Please let me know if you are still seeing the blocking page.

 

Thanks!

Na Zhang 

Product Engineer – ArcGIS for Power BI

0 Kudos
DLynch_GCWATER
New Contributor II

Thank you for helping with this issue. My data was shared publicly in ArcGIS online so I enabled anonymous access in the report with privacy as "none". It is resolved now by editing the credentials for the data source within PowerBI.

0 Kudos
RUIFLAMINOSANTOS
New Contributor

I Publish my BI report to the web however the map visuals are not displaying in the published dashboard, they work just fine in power bi desktop and online. It appears a message saying "este elemento visual não é suportado nos seguintes cenários: Live Connect para incorporar e publicar na web não autenticado por utilizado, publicar para a web e power bi server" google translated to "This visual element is not supported in the following scenarios: Live Connect for embedding and publishing on the web not authenticated by the user, publishing to the web, and Power BI server"

 

0 Kudos