Problem with Experience builder Table widget changing cell values when double click on the cell.

1119
11
09-22-2021 09:54 AM
Labels (1)
JoseBarrios1
Occasional Contributor

Hello everyone,

Does anyone having  problems with Exp. builder table widget?  When I double click on a cell to copy the value, the cell value changes (display) other cell value.  Does anyone having the the same problem?

JB

 

11 Replies
jcarlson
MVP Notable Contributor

Do you need the table editable? Just turn that feature off and double-clicking will just highlight the cell contents. If you need the table editable, you'll have to work around double-clicking as the "edit cell" shortcut.

Do you have a screenshot of this behavior? Is it changing another cell in the same row, or a different row?

- Josh Carlson
Kendall County GIS
0 Kudos
JoseBarrios1
Occasional Contributor

The table is not set to be editable (box is unchecked) The content on the cell is changing to dispaly the content of another cell. That is happeng to any cell , not just the name field. The behavior is also happening on all the other tables from other Exp. builder apps. Not sure what it is going on! (see attched pic!)

0 Kudos
jcarlson
MVP Notable Contributor

It almost seems like it's selecting a totally different feature from the table, since the two cells pictured are consistent.

Could you try this on the objectID column to see what row is being selected? If you try it on other rows, is the "offset" consistent?

- Josh Carlson
Kendall County GIS
0 Kudos
JoseBarrios1
Occasional Contributor

Hi Josh,

Thanks for your suggestion. I try but the table does not let me select the OBJECTID field. I created a index field with numbers and it is doing the same behavior. The values on the selected cell are changing randomly. Sometimes is the next row, the previous or the first. No idea what the heckkk is going on. I know that there was a new release of Exp builder yesterday and I had to re-link the tables. I have 3 app and all have the same issue! ...Frustrated!!!

JB

 

0 Kudos
BrittanyBurson
Regular Contributor

Good morning @JoseBarrios1 

I just tried to re-create this but I am not seeing the behavior. I also tried with a domain value like your example. I am using a hosted feature layer in both Chrome + Firefox. What kind of layer are you using?

JoseBarrios1
Occasional Contributor

Hi Brittany,

It is happening in both a hosted table and a hosted feauture layer on 3 different applcations...all in Exp. builder. It also happening in Firefox, Chrome and Edge. I also I just noticed that is happening only on cells (rows) that are not on the initial table view. All the cells after I scroll down the table content got affected. 

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi @JoseBarrios1 - it looks like this may be related to the recent Experience Builder update. Can you create a case with Esri Support so our development teams can take a look? Feel free to send me an email at pklingman@esri.com with your customer number and I can get one started for you. 

 

Thanks,

-Peter 

JBald
by
New Contributor III

@pklingman@esri.com

 I am having the same problem   everytime I double click a cell and change the contents of the cell then I and click the enter button,   the data  I typed ends up in a different row all together.

example changing contents of field 1    for object id # 77   ends up changing the contents of  field 1 in objectID #27         if I change field in object id #127   the change ends up in the corresponding field in objectid#77  consistently.      the offset is every 50 rows.      I was hoping to use this as a solution for our users to enter data from a browser,   but it fails.       Please let us know if there is an update on this problem

0 Kudos
aleecoro
New Contributor II

Hi @Peter_Klingman, I am having a similar issue where the tables are empty and not displaying any values. I tested in Chrome and Firefox and it's the same behavior. Thank you!