Problems with Web Adaptor

469
5
Jump to solution
12-02-2019 05:16 PM
Highlighted
Occasional Contributor

Hi,

I have an arcgis server installed on a Windows 7 machine, it is already using https, but without a valid certificate.

To configure WebAdaptor, use the https server link https://myhost:6443 and after configuration do not access the web adapter with https, only http. Now via webadaptor, go to http://myhost/arcgis/manager.

Without using webadaptor or https it works perfectly.

Why is this happening?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Contributor

Hi Sorato Marques‌,

In most situation this could just be that the IIS Server is not enabled for the binding on port 443 (HTTPS) hence the site will work only with http. Other situations, there could be a mix protocol both on IIS (http binding port 80 enabled but not port 443, could be happening in your situation) and ArcGIS Server (http and https enabled or just http only enabled, like on pre ArcGIS Server 10.4, which could be in this case)

Again depending on the version of Arcgis for Server, you may want to see the default protocol that the Arcgis Server is configured with. 

Enable HTTPS on your web server—ArcGIS Web Adaptor (IIS) Installation Guide | ArcGIS Enterprise (10.7 document) 

Enabling SSL on ArcGIS Server—Documentation (10.3 and 10.3.1) | ArcGIS Enterprise (10.3 document)

Hope this helps. 

View solution in original post

5 Replies
Highlighted
Esri Contributor

Hello Sorato Marques‌,

Just to confirm if you try to access ArcGIS Server manager over 'HTTPS' using your web adaptor does the page fail to load?

Example URL: https://hostname.domain.com/webadaptorname/manager

If you sign into the ArcGIS Server admin endpoint what URL is listed for the web adaptor?

  • ArcGIS Server Administrator Directory > Home > system >  webadaptor > webadaptorID > URL
  • Example URL: https://hostname.domain.com/server/admin/system/webadaptors/3fe5fd44-dbd3-4c0a-9662-2bc32aaecce8

If you open the web adaptor configuration page click on server and click next. What URL is listed to access the service directory?

  • "Use the following URL to access the Services Directory:"

Finally this problem may be caused by the invalid certificate. I would recommend configuring a valid certificate with ArcGIS Web Adaptor and ArcGIS Server.

Hope these suggestions are helpful.

Thanks,

Thomas.

Highlighted
MVP Frequent Contributor

"Windows 7, 8.1, and 10 are supported for basic testing and application development use only. They are not recommended for deployment in a production environment." ArcGIS Web Adaptor 10.7.x system requirements—ArcGIS Enterprise system requirements | Documentation ... 

That might be your problem. Running IIS on Win 7, or even 10, introduces all sorts of flaky instabilities. 

Highlighted
Esri Frequent Contributor

If you can't reach the IIS splash page via HTTPS, (https://myhost), then the problem is not with the web adaptor or Server, but the IIS instance.

Highlighted
Esri Contributor

Hi Sorato Marques‌,

In most situation this could just be that the IIS Server is not enabled for the binding on port 443 (HTTPS) hence the site will work only with http. Other situations, there could be a mix protocol both on IIS (http binding port 80 enabled but not port 443, could be happening in your situation) and ArcGIS Server (http and https enabled or just http only enabled, like on pre ArcGIS Server 10.4, which could be in this case)

Again depending on the version of Arcgis for Server, you may want to see the default protocol that the Arcgis Server is configured with. 

Enable HTTPS on your web server—ArcGIS Web Adaptor (IIS) Installation Guide | ArcGIS Enterprise (10.7 document) 

Enabling SSL on ArcGIS Server—Documentation (10.3 and 10.3.1) | ArcGIS Enterprise (10.3 document)

Hope this helps. 

View solution in original post

Highlighted
Occasional Contributor

Thank you