Select to view content in your preferred language

Is it normal to have to manually restart ArcGIS Server service after a server reboot?

1187
5
Jump to solution
09-18-2023 07:10 AM
RyanUthoff
Regular Contributor

We are having a problem with ArcGIS Enterprise not fully coming back online after a full server restart, forcing us to having to manually restart the ArcGIS Server service to bring it fully back online.

To explain, we have a four machine deployment. One Portal, two Server, and one Data Store. Those machines periodically get restarted for non-Esri patching (Windows, anti-virus, etc.). 

After those machines get restarted, everything appears to be operational, with the exception of being able to submit S123 forms. We get an error message in S123 saying it can't find the hosted feature service (or some variation of that error message).

Manually restarting the two ArcGIS Server services fixes the issue. 

However, we'd like to not have to manually restart the services every time the servers get restarted. Is there a reason why ArcGIS Enterprise doesn't come fully online after a server restart? Or is there anything we can do to ensure it comes fully back online so we don't have to manually restart it afterwards?

0 Kudos
1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

Hi @RyanUthoff ,

I ran into a similar issue with my ArcGIS Server instance.  To fix the issue, I created a .bat file with the following line:

net start "arcgis server"

I then configured a Group Policy to execute this BAT file upon startup:

1.  On the ArcGIS Server machine, open Local Group Policy Editor by going to Start > Run > gpedit.msc

JakeSkinner_0-1695047144318.png

2.  Navigate to Computer Configuration > Windows Settings > Scripts (Startup/Shutdown)

JakeSkinner_1-1695047144274.png

3.  Double-click Startup

4. Under the Scripts tab click Add

JakeSkinner_2-1695047198000.png

5.  For Script Name browse to the .bat file created previously

JakeSkinner_3-1695047272059.png

 

View solution in original post

5 Replies
JakeSkinner
Esri Esteemed Contributor

Hi @RyanUthoff ,

I ran into a similar issue with my ArcGIS Server instance.  To fix the issue, I created a .bat file with the following line:

net start "arcgis server"

I then configured a Group Policy to execute this BAT file upon startup:

1.  On the ArcGIS Server machine, open Local Group Policy Editor by going to Start > Run > gpedit.msc

JakeSkinner_0-1695047144318.png

2.  Navigate to Computer Configuration > Windows Settings > Scripts (Startup/Shutdown)

JakeSkinner_1-1695047144274.png

3.  Double-click Startup

4. Under the Scripts tab click Add

JakeSkinner_2-1695047198000.png

5.  For Script Name browse to the .bat file created previously

JakeSkinner_3-1695047272059.png

 

RyanUthoff
Regular Contributor

Awesome, I think that will work. Thank you!

0 Kudos
Ann-MarieFalkowski1
New Contributor III

Hello, 

This is a bug: https://support.esri.com/en-us/bug/upgrading-a-base-arcgis-enterprise-deployment-causes-th-bug-00014...

Last week the status was changed to "Fixed" but I haven't found a patch that includes this bug in the issues addressed. 

-Ann-Marie
berniejconnors
Regular Contributor

Hello,

        I have two suggestions:

  1. You should check the settings for the start up of the ArcGIS Server service.  I beleive there are settings to have the service start up immediately with Windows or to delay the start up of the service.  Esri's recommendation is to use the delayed start up for the ArcGIS Server service.
  2. Have you tried just restarting the service(s) that are being used by Survey123 instead of restarting the ArcGIS Server service?

Best regards,

Bernie.

0 Kudos
RyanUthoff
Regular Contributor

Thank you for your reply. The settings are already configured for a delay start up of the service. As far as restarting the services, it appears to be affecting all of them. We have 100+ hosted feature services so I'm not going to check them all, but all the ones I tried (along with reports from our end users) were not working. So it would be much simpler to restart the entire service instead of the individual services.

0 Kudos