Integrate ArcGIS Enterprise with Maximo Spatial

959
2
01-06-2021 11:51 AM
WilliamShoop
New Contributor III

Hello everyone,

 

Has anyone successfully integrated their secure ArcGIS Services with Maximo Spatial? Our organization has an internal ArcGIS Enterprise 10.7.1 system with secure feature services that need to be reached from Maximo Spatial and are receiving a "Token required" error. Researching I found this documentation: https://www.ibm.com/support/pages/configuring-maximo-spatial-arcgis-portal which explains setting up a Web Mapping Application inside our ArcGIS Portal. Doing this hasn't fixed the issue but I am unsure of how to properly create a Web Mapping Application inside the Portal. If someone has experience with this, it would greatly appreciated if you would please share your thoughts.

 

Thanks,

Bill

0 Kudos
2 Replies
Bud
by
Regular Contributor

Oh, you poor soul!

My team has spent the last 1.5 years trying to get Maximo Spatial working properly. After dozens of bug reports and hundreds of hours of effort, it's still not working quite right.

Unfortunately, I can't help with the token stuff (I'm not the map service administrator in my organization), but you could try:

1. Asking IBM support

2. Posting a question on the Maximo Spatial Community forum

3. Asking IBM staff directly (such as jmaior@br.ibm.com) 

Good luck.

mpc
by
Occasional Contributor

We're in the mist of updating our map config, after moving to Maximo 7.6.1 and Enterprise 10.8.1 using secure feature services. Are you using web services from Enterprise or a web map from Portal for the Maximo integration? If it's just web services you shouldn't need anything in the Web Map Configuration section. 

Under Map Security tick the Enable Token Security box and then enter the credentials. This assumes all services in use are secured with the same user and password.

mpc_1-1628031637839.png

 

 

0 Kudos